summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/iscan-plugin-gt-x820')
-rw-r--r--media-gfx/iscan-plugin-gt-x820/Manifest2
-rw-r--r--media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild91
-rw-r--r--media-gfx/iscan-plugin-gt-x820/metadata.xml20
3 files changed, 113 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-x820/Manifest b/media-gfx/iscan-plugin-gt-x820/Manifest
new file mode 100644
index 000000000000..5726da499ca9
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x820/Manifest
@@ -0,0 +1,2 @@
+DIST iscan-plugin-gt-x820-2.2.0-1.i386.rpm 490641 SHA256 aef57fde9829bb888dd091cd7423778a88511e4d580f519d06f43d097db80c84 SHA512 37f72ce8d71d315f51f45cd08c8865a2e613b8a6c6a27e7f4671bd5a796d10f3f9cffb954dd5f3875395f49244b090f5a2a4f2749d6c5d080ce4766faf7ccdf1 WHIRLPOOL fd5de9365d0ade03958e86e8f015a209abe47f3dea58550c057067c4a1986404c0d7b171958774ac0acb533d6c08ccf60e195baa64f1466bce7d30ff1c6f780e
+DIST iscan-plugin-gt-x820-2.2.0-1.x86_64.rpm 206774 SHA256 4be3bed1d6292822f7e963de183683a987db1f59a911688985b00af3d231b317 SHA512 342b034ae7cf1f2b346ffce8719a025e55df2295daaad896acb072e3e36b916f0503106293dc88340d4b1b732b8daa6f4d0681f843754824b757667940b5b545 WHIRLPOOL 726de2d88a2bfd16f2ad34318cfe90ea89f1a46091a7aaf97e232256f61f795caf271131414a7eb3fca3e2ded4963e068752774c351cd1c9f38bccf5619bcf1a
diff --git a/media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild b/media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild
new file mode 100644
index 000000000000..aa98f2e8f907
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x820/iscan-plugin-gt-x820-2.2.0.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit rpm versionator multilib
+
+MY_PV="$(get_version_component_range 1-3)"
+MY_PVR="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Epson Perfection V600 scanner plugin for SANE 'epkowa' backend"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="amd64? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.x86_64.rpm )
+ x86? ( http://dev.gentoo.org/~flameeyes/avasys/${PN}-${MY_PVR}.i386.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/opt/iscan/lib/libesintA1.so*"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}"/usr/share/iscan/*
+
+ dodoc usr/share/doc/*/*
+
+ # install scanner plugins
+ exeinto /opt/iscan/lib
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmds=(
+ "iscan-registry --COMMAND interpreter usb 0x04b8 0x013a /opt/iscan/lib/libesintA1 /usr/share/iscan/esfwA1.bin"
+ )
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file esfwA1.bin for Epson Perfection V600"
+ elog "has been installed in /usr/share/iscan."
+ elog
+
+ # Only register scanner on new installs
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ # Needed for scanner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/add}
+ done
+ elog "New firmware has been registered automatically."
+ elog
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/add}"
+ done
+ fi
+}
+
+pkg_prerm() {
+ # Only unregister on on uninstall
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/remove}
+ done
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/remove}"
+ done
+ fi
+}
diff --git a/media-gfx/iscan-plugin-gt-x820/metadata.xml b/media-gfx/iscan-plugin-gt-x820/metadata.xml
new file mode 100644
index 000000000000..16393b245a9d
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x820/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>nitro@legroom.net</email>
+ </maintainer>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit and 64-bit.
+
+ Supports the following models:
+
+ EPSON Perfection V600 Photo (GT-X820)
+ </longdescription>
+</pkgmetadata>