summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jp2a')
-rw-r--r--media-gfx/jp2a/jp2a-1.1.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-gfx/jp2a/jp2a-1.1.1.ebuild b/media-gfx/jp2a/jp2a-1.1.1.ebuild
index 3e88e9c7644d..6b66aafdfe5b 100644
--- a/media-gfx/jp2a/jp2a-1.1.1.ebuild
+++ b/media-gfx/jp2a/jp2a-1.1.1.ebuild
@@ -5,17 +5,19 @@ EAPI=8
DESCRIPTION="JPEG image to ASCII art converter"
HOMEPAGE="https://github.com/Talinx/jp2a/"
-SRC_URI="https://github.com/Talinx/jp2a/releases/download/v${PV}/jp2a-${PV}.tar.gz"
+SRC_URI="https://github.com/Talinx/jp2a/releases/download/v${PV}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x64-solaris"
IUSE="curl"
-RDEPEND="sys-libs/ncurses
- virtual/jpeg
+# TODO: restore ncurses support?
+# See https://github.com/gentoo/gentoo/pull/24218#issuecomment-1043795319
+RDEPEND="virtual/jpeg
curl? ( net-misc/curl )"
DEPEND="${RDEPEND}"
src_configure() {
- econf "$(use_enable curl)"
+ econf $(use_enable curl)
}