summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/kxstitch/kxstitch-2.1.0.ebuild')
-rw-r--r--media-gfx/kxstitch/kxstitch-2.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/kxstitch/kxstitch-2.1.0.ebuild b/media-gfx/kxstitch/kxstitch-2.1.0.ebuild
new file mode 100644
index 000000000000..3e24a1c98c3e
--- /dev/null
+++ b/media-gfx/kxstitch/kxstitch-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Program to create cross stitch patterns"
+HOMEPAGE="https://userbase.kde.org/KXStitch"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ $(add_qt_dep qtxml)
+ media-gfx/imagemagick[cxx]
+ x11-libs/libX11
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMON_DEPEND}
+ !media-gfx/kxstitch:4
+"