summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/mcomix/mcomix-1.00-r1.ebuild')
-rw-r--r--media-gfx/mcomix/mcomix-1.00-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-gfx/mcomix/mcomix-1.00-r1.ebuild b/media-gfx/mcomix/mcomix-1.00-r1.ebuild
new file mode 100644
index 000000000000..b1ca4fa54d6d
--- /dev/null
+++ b/media-gfx/mcomix/mcomix-1.00-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 eutils fdo-mime
+
+DESCRIPTION="A fork of comix, a GTK image viewer for comic book archives"
+HOMEPAGE="http://mcomix.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2.14[${PYTHON_USEDEP}]
+ virtual/jpeg
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf
+ !media-gfx/comix"
+
+DOCS=( ChangeLog README )
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ echo
+ elog "Additional packages are required to open most common comic files:"
+ elog
+ elog " cbr: app-arch/unrar"
+ elog " cbz: app-arch/unzip"
+ elog
+ elog "You can also add support for 7z or LHA archives by installing"
+ elog "app-arch/p7zip or app-arch/lha."
+ echo
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}