summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/nomacs/nomacs-3.4.ebuild')
-rw-r--r--media-gfx/nomacs/nomacs-3.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/nomacs/nomacs-3.4.ebuild b/media-gfx/nomacs/nomacs-3.4.ebuild
new file mode 100644
index 000000000000..51f52dbb23b3
--- /dev/null
+++ b/media-gfx/nomacs/nomacs-3.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils fdo-mime
+
+DESCRIPTION="Qt-based image viewer"
+HOMEPAGE="http://www.nomacs.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/3.4.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE="opencv raw tiff zip"
+
+REQUIRED_USE="
+ raw? ( opencv )
+ tiff? ( opencv )
+"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ >=media-gfx/exiv2-0.25:=
+ opencv? ( media-libs/opencv:=[-qt4] )
+ raw? ( >=media-libs/libraw-0.14:= )
+ tiff? ( media-libs/tiff:0 )
+ zip? ( dev-libs/quazip[qt5] )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${P}/ImageLounge"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_RAW=$(usex raw)
+ -DENABLE_TIFF=$(usex tiff)
+ -DENABLE_QUAZIP=$(usex zip)
+ -DUSE_SYSTEM_QUAZIP=ON
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}