summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pngcheck/pngcheck-3.0.2.ebuild')
-rw-r--r--media-gfx/pngcheck/pngcheck-3.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/pngcheck/pngcheck-3.0.2.ebuild b/media-gfx/pngcheck/pngcheck-3.0.2.ebuild
new file mode 100644
index 000000000000..ad45b82c58e8
--- /dev/null
+++ b/media-gfx/pngcheck/pngcheck-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Verifies the integrity of PNG, JNG and MNG files with internal checksums"
+HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
+SRC_URI="mirror://sourceforge/png-mng/${P}.tar.gz"
+
+LICENSE="HPND GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -f Makefile.unx \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -DUSE_ZLIB" \
+ ZLIB="-lz"
+}
+
+src_install() {
+ dobin png{check,split,-fix-IDAT-windowsize}
+ doman pngcheck.1 gpl/pngsplit.1
+
+ einstalldocs
+}