summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pngquant/pngquant-2.11.7.ebuild')
-rw-r--r--media-gfx/pngquant/pngquant-2.11.7.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/media-gfx/pngquant/pngquant-2.11.7.ebuild b/media-gfx/pngquant/pngquant-2.11.7.ebuild
deleted file mode 100644
index 5497e70ac515..000000000000
--- a/media-gfx/pngquant/pngquant-2.11.7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="command-line utility and library for lossy compression of PNG images"
-HOMEPAGE="https://pngquant.org/"
-SRC_URI="https://pngquant.org/${P}-src.tar.gz"
-
-LICENSE="GPL-3 HPND rwpng"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug lcms openmp cpu_flags_x86_sse2"
-
-RDEPEND="media-libs/libpng:0=
- media-gfx/libimagequant:=
- sys-libs/zlib:=
- lcms? ( media-libs/lcms:2 )"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- tc-export AR CC
- # Hand rolled configure script, so not all flags are supported.
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --with-libimagequant \
- $(use debug && echo --enable-debug) \
- $(use_enable cpu_flags_x86_sse2 sse) \
- $(use openmp && tc-has-openmp && echo --with-openmp) \
- $(use_with lcms lcms2) \
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin ${PN}
- doman ${PN}.1
- dodoc CHANGELOG README.md
-}