summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pycam/pycam-0.6.2.ebuild')
-rw-r--r--media-gfx/pycam/pycam-0.6.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-gfx/pycam/pycam-0.6.2.ebuild b/media-gfx/pycam/pycam-0.6.2.ebuild
new file mode 100644
index 000000000000..d26eca4bad30
--- /dev/null
+++ b/media-gfx/pycam/pycam-0.6.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="Open Source CAM - Toolpath Generation for 3-Axis CNC machining"
+HOMEPAGE="http://pycam.sourceforge.net/"
+SRC_URI="https://github.com/SebKuzminsky/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DEPEND="
+ dev-python/pygtk
+ dev-python/pygtkglext
+ dev-python/pyopengl
+ dev-python/librsvg-python
+"
+RDEPEND="${DEPEND}"