summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sam2p/sam2p-0.49.1.ebuild')
-rw-r--r--media-gfx/sam2p/sam2p-0.49.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/sam2p/sam2p-0.49.1.ebuild b/media-gfx/sam2p/sam2p-0.49.1.ebuild
new file mode 100644
index 000000000000..235b7cafa1c3
--- /dev/null
+++ b/media-gfx/sam2p/sam2p-0.49.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Utility to convert raster images to EPS, PDF and many others"
+HOMEPAGE="http://code.google.com/p/sam2p/"
+SRC_URI="http://sam2p.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="examples gif"
+
+RDEPEND=""
+DEPEND="dev-lang/perl"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.45-fbsd.patch \
+ "${FILESDIR}"/${PN}-0.49.1-build.patch \
+ "${FILESDIR}"/${PN}-0.49.1-gcc48.patch \
+ "${FILESDIR}"/${PN}-0.49-glibc-2.20.patch
+ eautoreconf
+ tc-export CXX
+}
+
+src_configure() {
+ econf --enable-lzw $(use_enable gif)
+}
+
+src_install() {
+ dobin sam2p
+ dodoc README
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}