summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/scantailor-advanced/files')
-rw-r--r--media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-bogus-dep.patch37
-rw-r--r--media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-desktopfile.patch23
-rw-r--r--media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-qt-5.15.patch87
3 files changed, 147 insertions, 0 deletions
diff --git a/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-bogus-dep.patch b/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-bogus-dep.patch
new file mode 100644
index 000000000000..553c108c19cf
--- /dev/null
+++ b/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-bogus-dep.patch
@@ -0,0 +1,37 @@
+--- a/CMakeLists.txt 2020-05-31 01:09:58.634978658 +0200
++++ b/CMakeLists.txt 2020-05-31 01:12:51.011307579 +0200
+@@ -298,7 +298,6 @@
+ find_package(Qt5Gui ${qt_min_version} REQUIRED)
+ find_package(Qt5Widgets ${qt_min_version} REQUIRED)
+ find_package(Qt5Xml ${qt_min_version} REQUIRED)
+-find_package(Qt5Network ${qt_min_version} REQUIRED)
+ find_package(Qt5LinguistTools ${qt_min_version} REQUIRED)
+ find_package(Qt5OpenGL ${qt_min_version} REQUIRED)
+
+@@ -311,8 +310,6 @@
+ link_directories(${Qt5Widgets_LIBRARIES})
+ include_directories(${Qt5Xml_INCLUDE_DIRS})
+ link_directories(${Qt5Xml_LIBRARIES})
+-include_directories(${Qt5Network_INCLUDE_DIRS})
+-link_directories(${Qt5Network_LIBRARIES})
+ include_directories(${Qt5OpenGL_INCLUDE_DIRS})
+ link_directories(${Qt5OpenGL_LIBRARIES})
+ include_directories(${Qt5LinguistTools_INCLUDE_DIRS})
+@@ -578,7 +575,7 @@
+ scantailor
+ fix_orientation page_split deskew select_content page_layout output stcore
+ dewarping zones interaction imageproc math foundation
+- ${Qt5Core_LIBRARIES} ${Qt5GUI_LIBRARIES} ${Qt5Widgets_LIBRARIES} ${Qt5Xml_LIBRARIES} ${Qt5Network_LIBRARIES}
++ ${Qt5Core_LIBRARIES} ${Qt5GUI_LIBRARIES} ${Qt5Widgets_LIBRARIES} ${Qt5Xml_LIBRARIES}
+ ${Qt5OpenGL_LIBRARIES} ${Qt5LinguistTools_LIBRARIES} ${EXTRA_LIBS}
+ )
+
+@@ -639,7 +636,7 @@
+ qt5_libs
+ ${Qt5Widgets_LIBRARIES} ${Qt5Gui_LIBRARIES}
+ ${Qt5Core_LIBRARIES} ${Qt5Xml_LIBRARIES}
+- ${Qt5Network_LIBRARIES} ${Qt5OpenGL_LIBRARIES}
++ ${Qt5OpenGL_LIBRARIES}
+ )
+
+ foreach (target ${qt5_libs})
diff --git a/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-desktopfile.patch b/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-desktopfile.patch
new file mode 100644
index 000000000000..cececbb84f43
--- /dev/null
+++ b/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-desktopfile.patch
@@ -0,0 +1,23 @@
+From e4125b66138c4258f13e69dc4bd8e6df41323599 Mon Sep 17 00:00:00 2001
+From: 4lex4 <4lex49@zoho.com>
+Date: Tue, 27 Aug 2019 17:30:50 +0300
+Subject: [PATCH] ~ Remove a deprecated value from the .desktop file
+
+---
+ resources/unix/scantailor.desktop | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/resources/unix/scantailor.desktop b/resources/unix/scantailor.desktop
+index 9e49d5e..4df7d97 100644
+--- a/resources/unix/scantailor.desktop
++++ b/resources/unix/scantailor.desktop
+@@ -7,5 +7,5 @@ Icon=ScanTailor
+ Terminal=false
+ X-MultipleArgs=false
+ Type=Application
+-Categories=Graphics;Applications;
++Categories=Graphics;
+ MimeType=application/x-scantailor-project;
+--
+2.26.2
+
diff --git a/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-qt-5.15.patch b/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-qt-5.15.patch
new file mode 100644
index 000000000000..4ed357025622
--- /dev/null
+++ b/media-gfx/scantailor-advanced/files/scantailor-advanced-1.0.16-qt-5.15.patch
@@ -0,0 +1,87 @@
+diff -ur a/filters/output/OutputGenerator.cpp b/filters/output/OutputGenerator.cpp
+--- a/filters/output/OutputGenerator.cpp 2018-07-17 04:04:23.000000000 +0200
++++ b/filters/output/OutputGenerator.cpp 2020-05-29 12:15:28.759822806 +0200
+@@ -25,6 +25,7 @@
+ #include <imageproc/ImageCombination.h>
+ #include <QDebug>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QtCore/QSettings>
+ #include <boost/bind.hpp>
+ #include "DebugImages.h"
+@@ -2666,4 +2667,4 @@
+ posterizationOptions.isForceBlackAndWhite(), 0, qRound(background_color.lightnessF() * 255))
+ .getImage();
+ }
+-} // namespace output
+\ Chybí znak konce řádku na konci souboru
++} // namespace output
+diff -ur a/filters/page_layout/ImageView.cpp b/filters/page_layout/ImageView.cpp
+--- a/filters/page_layout/ImageView.cpp 2018-07-17 04:04:23.000000000 +0200
++++ b/filters/page_layout/ImageView.cpp 2020-05-29 12:14:09.691546103 +0200
+@@ -27,6 +27,7 @@
+ #include <imageproc/Transform.h>
+ #include <QMouseEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <boost/bind.hpp>
+ #include <boost/lambda/lambda.hpp>
+ #include "ImagePresentation.h"
+@@ -1160,4 +1161,4 @@
+ bool ImageView::isShowingMiddleRectEnabled() const {
+ return (!m_nullContentRect && m_settings->isShowingMiddleRectEnabled()) || m_alignment.isNull();
+ }
+-} // namespace page_layout
+\ Chybí znak konce řádku na konci souboru
++} // namespace page_layout
+diff -ur a/filters/select_content/ContentBoxFinder.cpp b/filters/select_content/ContentBoxFinder.cpp
+--- a/filters/select_content/ContentBoxFinder.cpp 2018-07-17 04:04:23.000000000 +0200
++++ b/filters/select_content/ContentBoxFinder.cpp 2020-05-29 12:12:39.023619751 +0200
+@@ -19,6 +19,7 @@
+ #include "ContentBoxFinder.h"
+ #include <QDebug>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <cmath>
+ #include <queue>
+ #include "DebugImages.h"
+@@ -1353,4 +1354,4 @@
+
+ return m_sedm;
+ }
+-} // namespace select_content
+\ Chybí znak konce řádku na konci souboru
++} // namespace select_content
+diff -ur a/ImageViewBase.cpp b/ImageViewBase.cpp
+--- a/ImageViewBase.cpp 2018-07-17 04:04:23.000000000 +0200
++++ b/ImageViewBase.cpp 2020-05-29 11:58:54.720220475 +0200
+@@ -24,6 +24,7 @@
+ #include <QPointer>
+ #include <QScrollBar>
+ #include <QSettings>
++#include <QPainterPath>
+ #include <QtWidgets/QMainWindow>
+ #include <QtWidgets/QStatusBar>
+ #include "BackgroundExecutor.h"
+diff -ur a/zones/ZoneContextMenuInteraction.cpp b/zones/ZoneContextMenuInteraction.cpp
+--- a/zones/ZoneContextMenuInteraction.cpp 2018-07-17 04:04:23.000000000 +0200
++++ b/zones/ZoneContextMenuInteraction.cpp 2020-05-29 12:10:53.079190198 +0200
+@@ -21,6 +21,7 @@
+ #include <QMenu>
+ #include <QMessageBox>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QSignalMapper>
+ #include <boost/bind.hpp>
+ #include "ImageViewBase.h"
+diff -ur a/zones/ZoneDefaultInteraction.cpp b/zones/ZoneDefaultInteraction.cpp
+--- a/zones/ZoneDefaultInteraction.cpp 2018-07-17 04:04:23.000000000 +0200
++++ b/zones/ZoneDefaultInteraction.cpp 2020-05-29 12:09:24.276172092 +0200
+@@ -19,6 +19,7 @@
+ #include "ZoneDefaultInteraction.h"
+ #include <QMouseEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include "ImageViewBase.h"
+ #include "SerializableSpline.h"
+ #include "ZoneInteractionContext.h"