summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild')
-rw-r--r--media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
new file mode 100644
index 000000000000..dd314bc752d8
--- /dev/null
+++ b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Converts SVG files to PDFs or reportlab graphics"
+HOMEPAGE="https://github.com/sarnold/svg2rlg https://pypi.python.org/pypi/svg2rlg/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/svg2rlg.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ nosetests -sx test_svg2rlg.py || die "Test failed with ${EPYTHON}"
+}