summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gpicview/files/gpicview-fix-animated-gifs.patch13
-rw-r--r--media-gfx/gpicview/files/gpicview-main_win_open-dummy-return.patch13
-rw-r--r--media-gfx/gpicview/gpicview-0.2.5-r3.ebuild31
3 files changed, 57 insertions, 0 deletions
diff --git a/media-gfx/gpicview/files/gpicview-fix-animated-gifs.patch b/media-gfx/gpicview/files/gpicview-fix-animated-gifs.patch
new file mode 100644
index 000000000000..88867fbe31ad
--- /dev/null
+++ b/media-gfx/gpicview/files/gpicview-fix-animated-gifs.patch
@@ -0,0 +1,13 @@
+diff --git a/src/image-view.c b/src/image-view.c
+index b367f2a..1368620 100644
+--- a/src/image-view.c
++++ b/src/image-view.c
+@@ -343,7 +343,7 @@ void image_view_clear( ImageView* iv )
+
+ void image_view_set_pixbuf( ImageView* iv, GdkPixbuf* pixbuf )
+ {
+- if( pixbuf != iv->pix )
++
+ {
+ image_view_clear( iv );
+ if( G_LIKELY(pixbuf) )
diff --git a/media-gfx/gpicview/files/gpicview-main_win_open-dummy-return.patch b/media-gfx/gpicview/files/gpicview-main_win_open-dummy-return.patch
new file mode 100644
index 000000000000..0f4e3bde251c
--- /dev/null
+++ b/media-gfx/gpicview/files/gpicview-main_win_open-dummy-return.patch
@@ -0,0 +1,13 @@
+diff --git a/src/main-win.c b/src/main-win.c
+index 32f6433..bf5feba 100644
+--- a/src/main-win.c
++++ b/src/main-win.c
+@@ -378,7 +378,7 @@ gboolean main_win_open( MainWin* mw, const char* file_path, ZoomMode zoom )
+ image_list_sort_by_name( mw->img_list, GTK_SORT_DESCENDING );
+ if (image_list_get_first(mw->img_list))
+ main_win_open(mw, image_list_get_current_file_path(mw->img_list), zoom);
+- return;
++ return 1;
+ }
+
+
diff --git a/media-gfx/gpicview/gpicview-0.2.5-r3.ebuild b/media-gfx/gpicview/gpicview-0.2.5-r3.ebuild
new file mode 100644
index 000000000000..36eaa0fd8f83
--- /dev/null
+++ b/media-gfx/gpicview/gpicview-0.2.5-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="A Simple and Fast Image Viewer for X"
+HOMEPAGE="http://lxde.sourceforge.net/gpicview"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+
+RDEPEND="media-libs/libjpeg-turbo
+ x11-libs/gtk+:3[X]"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/Fix-displaying-images-with-GTK3.patch"
+ "${FILESDIR}/${PN}-main_win_open-dummy-return.patch"
+ "${FILESDIR}/${PN}-fix-animated-gifs.patch"
+)
+
+src_configure() {
+ econf --enable-gtk3
+}