summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exact-image/exact-image-1.0.2.ebuild1
-rw-r--r--media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/media-gfx/exact-image/exact-image-1.0.2.ebuild b/media-gfx/exact-image/exact-image-1.0.2.ebuild
index 0cea0d26cf53..2c2e93b4fffd 100644
--- a/media-gfx/exact-image/exact-image-1.0.2.ebuild
+++ b/media-gfx/exact-image/exact-image-1.0.2.ebuild
@@ -39,6 +39,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-gcc6.patch
"${FILESDIR}"/${P}-g++.patch
+ "${FILESDIR}"/${P}-dcraw.patch
)
src_prepare() {
diff --git a/media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch b/media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch
new file mode 100644
index 000000000000..ba609c294b17
--- /dev/null
+++ b/media-gfx/exact-image/files/exact-image-1.0.2-dcraw.patch
@@ -0,0 +1,11 @@
+--- a/codecs/dcraw.h 2020-09-10 08:42:19.905105346 +0200
++++ b/codecs/dcraw.h 2020-09-10 08:47:50.826316874 +0200
+@@ -9956,7 +9956,7 @@
+ strncpy (th->desc, desc, 512);
+ strncpy (th->make, make, 64);
+ strncpy (th->model, model, 64);
+- strcpy (th->soft, "dcraw v"DCRAW_VERSION);
++ strcpy (th->soft, "dcraw v" DCRAW_VERSION);
+ t = localtime (&timestamp);
+ sprintf (th->date, "%04d:%02d:%02d %02d:%02d:%02d",
+ t->tm_year+1900,t->tm_mon+1,t->tm_mday,t->tm_hour,t->tm_min,t->tm_sec);