summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/yafaray/Manifest1
-rw-r--r--media-gfx/yafaray/metadata.xml20
-rw-r--r--media-gfx/yafaray/yafaray-3.5.1.ebuild109
3 files changed, 125 insertions, 5 deletions
diff --git a/media-gfx/yafaray/Manifest b/media-gfx/yafaray/Manifest
index eb4cb6dcc74b..e5363adde333 100644
--- a/media-gfx/yafaray/Manifest
+++ b/media-gfx/yafaray/Manifest
@@ -1 +1,2 @@
+DIST yafaray-3.5.1.tar.gz 1136455 BLAKE2B 6002f3b96f3626b83f57015eaf3ddd53dcb6b6fd863277912f7fec06e4f176ec81dc48b889a068e6259edf17727dd04d4b1bbc51b571bfe6aad5e48148201e2e SHA512 3ead4d8becd2d524aa5bb4bbde4b9d98b56f8a38d872e7aa49ba19081094406336def02e9bf1503e424ca8e6cade0db4b042214cea8f9345bd4fc542c9346dbe
DIST yafaray-core-3.4.1.tar.gz 1136077 BLAKE2B a2ce3945f52315084ee744ff4a6733255018196f0000ca6b1786fbd2ec49ade64cb62e98dfba95dca4dec361f47235d59a8c9bd95ee7d095214fc0afbdcb1ee4 SHA512 a9116273fbc2aaaadbc38a65b1eaaa502070ff06f8a2929e880714a9db57188e65cf319c20a3f96e08146af36a67aea139709a633eb024be65319a64330e6f68
diff --git a/media-gfx/yafaray/metadata.xml b/media-gfx/yafaray/metadata.xml
index 2c614e94cc33..1200537158aa 100644
--- a/media-gfx/yafaray/metadata.xml
+++ b/media-gfx/yafaray/metadata.xml
@@ -10,13 +10,23 @@
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
- YafaRay is a raytracing open source render engine. Raytracing is a rendering technique for generating realistic images by tracing the path of light through a 3D scene.
- An render engine consists of a "faceless" computer program that interacts with a host 3D application to provide very specific raytracing capabilties "on demand". Blender 3D is the host application of YafaRay.
+ YafaRay is a raytracing open source render engine. Raytracing is a
+ rendering technique for generating realistic images by tracing the
+ path of light through a 3D scene.
+ An render engine consists of a "faceless" computer program that
+ interacts with a host 3D application to provide very specific
+ raytracing capabilties "on demand".
</longdescription>
<use>
- <flag name="fastmath">Enable mathematic approximations to make code faster</flag>
- <flag name="fasttrig">Enable trigonometric approximations to make code faster</flag>
- <flag name="opencv">Use <pkg>media-libs/opencv</pkg></flag>
+ <flag name="fastmath">
+ Enable mathematic approximations to make code faster
+ </flag>
+ <flag name="fasttrig">
+ Enable trigonometric approximations to make code faster
+ </flag>
+ <flag name="opencv">
+ Add support for <pkg>media-libs/opencv</pkg> image processing.
+ </flag>
</use>
</pkgmetadata>
diff --git a/media-gfx/yafaray/yafaray-3.5.1.ebuild b/media-gfx/yafaray/yafaray-3.5.1.ebuild
new file mode 100644
index 000000000000..240025c99ebc
--- /dev/null
+++ b/media-gfx/yafaray/yafaray-3.5.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+# doesn't build with ninja when qt5 and python USE flags are both enabled
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake flag-o-matic python-single-r1
+
+DESCRIPTION="A free open-source montecarlo raytracing engine"
+# Regular homepage is currently down. Upstream is working on this.
+HOMEPAGE="https://www.yafaray.org https://github.com/YafaRay/libYafaRay"
+SRC_URI="https://github.com/YafaRay/libYafaRay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/libYafaRay-${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fastmath +fasttrig jpeg opencv openexr png python qt5 tiff truetype"
+RESTRICT="test"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+# Note: according to upstream, the blender plugin doesn't work with >=blender-2.8 (yet).
+RDEPEND="
+ dev-libs/libxml2:2
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg )
+ opencv? ( media-libs/opencv:= )
+ openexr? ( media-libs/openexr:= )
+ png? ( media-libs/libpng:= )
+ python? ( ${PYTHON_DEPS} )
+ qt5? ( dev-qt/qtwidgets:5 )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype:2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="python? ( dev-lang/swig )"
+
+DOCS=( AUTHORS.md CHANGELOG.md CODING.md INSTALL.md README.md )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ append-flags -pthread
+ append-ldflags -pthread
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # enabling BLENDER_ADDON doesn't build anything, but set's some wierd
+ # installation paths, so keep it off and install the files manually.
+ -DBLENDER_ADDON=OFF
+ -DFAST_MATH=$(usex fastmath)
+ -DFAST_TRIG=$(usex fasttrig)
+ -DWITH_Freetype=$(usex truetype)
+ -DWITH_JPEG=$(usex jpeg)
+ -DWITH_OpenCV=$(usex opencv)
+ -DWITH_OpenEXR=$(usex openexr)
+ -DWITH_PNG=$(usex png)
+ -DWITH_QT=$(usex qt5)
+ -DWITH_TIFF=$(usex tiff)
+ -DWITH_XML_LOADER=ON
+ -DWITH_XMLImport=ON
+ -DWITH_YAF_PY_BINDINGS=$(usex python)
+ -DWITH_YAF_RUBY_BINDINGS=OFF
+ -DYAF_DOC_DIR=share/doc/${PF}
+ -DYAF_LIB_DIR=$(get_libdir)
+ )
+
+ if use python; then
+ mycmakeargs+=( -DYAF_PY_VERSION=${EPYTHON#python} )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ if use python; then
+ python_domodule "${BUILD_DIR}/src/bindings/yafaray_v3_interface.py"
+ mv "${ED}"/usr/$(get_libdir)/_yafaray_v3_interface.so "${ED}"/$(python_get_sitedir)/ || die
+ rm -v "${ED}"/usr/$(get_libdir)/yafaray_v3_interface.py || die
+
+ if use qt5; then
+ python_domodule "${BUILD_DIR}/src/bindings/yafqt.py"
+ mv "${ED}"/usr/$(get_libdir)/_yafqt.so "${ED}"/$(python_get_sitedir)/ || die
+ rm -v "${ED}"/usr/$(get_libdir)/yafqt.py || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ einfo "To confirm your installation is working as expected, run"
+ einfo "yafaray-xml with /usr/share/yafaray/tests/test01/test01.xml"
+ einfo "as an input file, then compare the result to"
+ einfo "'/usr/share/yafaray/tests/test01/test01 - expected render result.png'"
+}