summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ipe/Manifest2
-rw-r--r--media-gfx/ipe/files/ipe-7.1.3-gold.patch30
-rw-r--r--media-gfx/ipe/ipe-7.1.2.ebuild77
-rw-r--r--media-gfx/ipe/ipe-7.1.3.ebuild80
-rw-r--r--media-gfx/ipe/metadata.xml17
5 files changed, 0 insertions, 206 deletions
diff --git a/media-gfx/ipe/Manifest b/media-gfx/ipe/Manifest
deleted file mode 100644
index b3266263ba9c..000000000000
--- a/media-gfx/ipe/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST ipe-7.1.2-src.tar.gz 1416404 BLAKE2B e3eb5e92d7713703eaac5c6591a2553e9ba428d7a4d99cb9b5b88212f7bb8f72b7f315db4949a8665ed26c8d11e9fe16a2416291b0613ba28365b3a5e436dbb6 SHA512 9d49c5f116a6271fce5a5a6c77cad64e348b17b9b02d1be8bece341231ebc15f642d6af49e73958e4d26814eafc52be38855e4d24e8cf44488da6a752151a189
-DIST ipe-7.1.3-src.tar.gz 1497624 BLAKE2B 2e2c635d4797c5b3b1c7101f6c5112437caf6c3bf013ce5edd3439827d47aceb6d6b7aa33c21d758b9a8b8c0a265d4ee96617d0ae9fc8db97034991942bd9ed2 SHA512 eea85ed6f4bc23e746222e01f4cdfd101c9c18aeb19fcba9abff565a65614a2a5e6630ddf9f7b024cac225582a34238a22f6fc5cf7dcc3733b8281ce844ef23d
diff --git a/media-gfx/ipe/files/ipe-7.1.3-gold.patch b/media-gfx/ipe/files/ipe-7.1.3-gold.patch
deleted file mode 100644
index a28fafa15c43..000000000000
--- a/media-gfx/ipe/files/ipe-7.1.3-gold.patch
+++ /dev/null
@@ -1,30 +0,0 @@
- src/ipe/Makefile | 2 +-
- src/ipescript/Makefile | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/ipe/Makefile b/src/ipe/Makefile
-index 21ac500..5a7a1ad 100644
---- a/src/ipe/Makefile
-+++ b/src/ipe/Makefile
-@@ -10,7 +10,7 @@ TARGET = $(call exe_target,ipe)
- CPPFLAGS += -I../include -I../ipecanvas -I../ipecairo -I../ipelua \
- $(LUA_CFLAGS) $(UI_CFLAGS) $(CAIRO_CFLAGS) $(ZLIB_CFLAGS)
- LIBS += -L$(buildlib) -lipecanvas -lipecairo -lipelua -lipe -lipeui \
-- $(LUA_LIBS) $(UI_LIBS) $(CAIRO_LIBS) $(ZLIB_LIBS)
-+ $(LUA_LIBS) $(UI_LIBS) $(CAIRO_LIBS) $(ZLIB_LIBS) -ldl
-
- CPPFLAGS += -DIPELETDIR=\"$(IPELETDIR)\"
- CPPFLAGS += -DIPELUADIR=\"$(IPELUADIR)\"
-diff --git a/src/ipescript/Makefile b/src/ipescript/Makefile
-index ff35fd9..2315f1f 100644
---- a/src/ipescript/Makefile
-+++ b/src/ipescript/Makefile
-@@ -8,7 +8,7 @@ include ../common.mak
- TARGET = $(call exe_target,ipescript)
-
- CPPFLAGS += -I../include -I../ipelua $(LUA_CFLAGS)
--LIBS += -L$(buildlib) -lipelua -lipe $(LUA_LIBS)
-+LIBS += -L$(buildlib) -lipelua -lipe $(LUA_LIBS) -ldl
-
- CPPFLAGS += -DIPELETDIR=\"$(IPELETDIR)\"
- CPPFLAGS += -DIPESTYLEDIR=\"$(IPESTYLEDIR)\"
diff --git a/media-gfx/ipe/ipe-7.1.2.ebuild b/media-gfx/ipe/ipe-7.1.2.ebuild
deleted file mode 100644
index 95a1767ba501..000000000000
--- a/media-gfx/ipe/ipe-7.1.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils toolchain-funcs qt4-r2
-
-DESCRIPTION="Drawing editor for creating figures in PDF or PS formats"
-HOMEPAGE="http://ipe7.sourceforge.net/"
-SRC_URI="mirror://sourceforge/ipe7/${PN}/7.1.0/${P}-src.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="app-text/texlive-core
- dev-lang/lua
- media-libs/freetype:2
- x11-libs/cairo
- dev-qt/qtcore:4
- dev-qt/qtgui:4"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${P}/src"
-
-search_urw_fonts() {
- # colon-separated list of paths
- local texmfdist="$(kpsewhich -var-value=TEXMFDIST)"
- # according to TeX directory structure
- local urwdir=fonts/type1/urw
- # add colon as field separator
- local IFS="${IFS}:" dir
- for dir in ${texmfdist}; do
- if [[ -d ${dir}/${urwdir} ]]; then
- URWFONTDIR="${dir}/${urwdir}"
- return 0
- fi
- done
- return 1
-}
-
-pkg_setup() {
- if search_urw_fonts; then
- einfo "URW fonts found in ${URWFONTDIR}"
- else
- ewarn "Could not find directory containing URW fonts"
- ewarn "Ipe will not function properly without them."
- fi
-}
-
-src_prepare() {
- sed -i \
- -e 's/fpic/fPIC/' \
- -e 's/moc-qt4/moc/' \
- -e "s:\$(IPEPREFIX)/lib:\$(IPEPREFIX)/$(get_libdir):g" \
- config.mak || die
- sed -i -e 's/install -s/install/' common.mak || die
-
-}
-
-src_compile() {
- emake \
- CXX=$(tc-getCXX) \
- IPEPREFIX="${EPREFIX}/usr" \
- IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html"
-}
-
-src_install() {
- emake install \
- IPEPREFIX="${EPREFIX}/usr" \
- IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html" \
- INSTALL_ROOT="${ED}"
- dodoc ../{news,readme}.txt
- doicon ipe/icons/ipe.png
- make_desktop_entry ipe Ipe ipe
-}
diff --git a/media-gfx/ipe/ipe-7.1.3.ebuild b/media-gfx/ipe/ipe-7.1.3.ebuild
deleted file mode 100644
index c25f67000442..000000000000
--- a/media-gfx/ipe/ipe-7.1.3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="Drawing editor for creating figures in PDF or PS formats"
-HOMEPAGE="http://ipe7.sourceforge.net/"
-SRC_URI="mirror://sourceforge/ipe7/${PN}/7.1.0/${P}-src.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- app-text/texlive-core
- dev-lang/lua
- media-libs/freetype:2
- x11-libs/cairo
- dev-qt/qtcore:4
- dev-qt/qtgui:4"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S="${WORKDIR}/${P}/src"
-
-search_urw_fonts() {
- # colon-separated list of paths
- local texmfdist="$(kpsewhich -var-value=TEXMFDIST)"
- # according to TeX directory structure
- local urwdir=fonts/type1/urw
- # add colon as field separator
- local IFS="${IFS}:" dir
- for dir in ${texmfdist}; do
- if [[ -d ${dir}/${urwdir} ]]; then
- URWFONTDIR="${dir}/${urwdir}"
- return 0
- fi
- done
- return 1
-}
-
-pkg_setup() {
- if search_urw_fonts; then
- einfo "URW fonts found in ${URWFONTDIR}"
- else
- ewarn "Could not find directory containing URW fonts"
- ewarn "Ipe will not function properly without them."
- fi
-}
-
-src_prepare() {
- sed -i \
- -e 's/fpic/fPIC/' \
- -e 's/moc-qt4/moc/' \
- -e "s:\$(IPEPREFIX)/lib:\$(IPEPREFIX)/$(get_libdir):g" \
- config.mak || die
- sed -i -e 's/install -s/install/' common.mak || die
-
- epatch "${FILESDIR}"/${P}-gold.patch
-}
-
-src_compile() {
- emake \
- CXX=$(tc-getCXX) \
- IPEPREFIX="${EPREFIX}/usr" \
- IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html"
-}
-
-src_install() {
- emake install \
- IPEPREFIX="${EPREFIX}/usr" \
- IPEDOCDIR="${EPREFIX}/usr/share/doc/${PF}/html" \
- INSTALL_ROOT="${ED}"
- dodoc ../{news,readme}.txt
- doicon ipe/icons/ipe.png
- make_desktop_entry ipe Ipe ipe
-}
diff --git a/media-gfx/ipe/metadata.xml b/media-gfx/ipe/metadata.xml
deleted file mode 100644
index 6446d13a5fe6..000000000000
--- a/media-gfx/ipe/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- Ipe is a drawing editor for creating figures in PDF or
- (encapsulated) Postscript format. Ipe supports making small figures
- for inclusion into LaTeX documents as well as making multi-page PDF
- presentations.
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">ipe7</remote-id>
- </upstream>
-</pkgmetadata>