summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/adplug/adplug-2.2.1.ebuild')
-rw-r--r--media-libs/adplug/adplug-2.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/adplug/adplug-2.2.1.ebuild b/media-libs/adplug/adplug-2.2.1.ebuild
new file mode 100644
index 000000000000..01188172bcd5
--- /dev/null
+++ b/media-libs/adplug/adplug-2.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
+HOMEPAGE="http://adplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 x86"
+IUSE="debug static-libs"
+
+RDEPEND=">=dev-cpp/libbinio-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO )
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"usr/lib*/lib${PN}.la
+}