summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/babl/babl-9999.ebuild')
-rw-r--r--media-libs/babl/babl-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/media-libs/babl/babl-9999.ebuild b/media-libs/babl/babl-9999.ebuild
index 4efedaf83c70..5b95b2a9f3d6 100644
--- a/media-libs/babl/babl-9999.ebuild
+++ b/media-libs/babl/babl-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
VALA_USE_DEPEND=vapigen
@@ -12,8 +12,8 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/babl.git"
SRC_URI=""
else
- SRC_URI="https://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv -sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+ SRC_URI="https://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv -sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="A dynamic, any to any, pixel format conversion library"
@@ -29,18 +29,19 @@ BDEPEND="
vala? ( $(vala_depend) )
"
RDEPEND="
- introspection? ( >=dev-libs/gobject-introspection-1.32:= )
- lcms? ( >=media-libs/lcms-2.8:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1.72:= )
+ lcms? ( >=media-libs/lcms-2.13.1:2 )
"
DEPEND="${RDEPEND}"
src_prepare() {
default
gnome2_environment_reset
- use vala && vala_src_prepare
}
src_configure() {
+ use vala && vala_setup
+
# Automagic rsvg support is just for website generation we do not call,
# so we don't need to fix it
# w3m is used for dist target thus no issue for us that it is automagically