summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/bcg729/bcg729-1.0.4-r1.ebuild')
-rw-r--r--media-libs/bcg729/bcg729-1.0.4-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/bcg729/bcg729-1.0.4-r1.ebuild b/media-libs/bcg729/bcg729-1.0.4-r1.ebuild
index ce3201c782e7..04926f70bcfb 100644
--- a/media-libs/bcg729/bcg729-1.0.4-r1.ebuild
+++ b/media-libs/bcg729/bcg729-1.0.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,11 @@ RDEPEND="
S=${WORKDIR}/${P/_/-}
DOCS=( AUTHORS NEWS README.md )
+src_prepare() {
+ sed -i -e '/-Werror/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
src_configure() {
mycmakeargs=(
-DENABLE_STATIC=$(usex static-libs)