summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/cogl/cogl-1.22.4.ebuild')
-rw-r--r--media-libs/cogl/cogl-1.22.4.ebuild37
1 files changed, 11 insertions, 26 deletions
diff --git a/media-libs/cogl/cogl-1.22.4.ebuild b/media-libs/cogl/cogl-1.22.4.ebuild
index 7061df2b3cde..2191b69cd4aa 100644
--- a/media-libs/cogl/cogl-1.22.4.ebuild
+++ b/media-libs/cogl/cogl-1.22.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit gnome2 multilib virtualx
+inherit gnome2 multilib
DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
HOMEPAGE="https://www.cogl3d.org/"
@@ -12,7 +12,7 @@ LICENSE="MIT BSD"
SLOT="1.0/20" # subslot = .so version
# doc and profile disable for now due to bugs #484750 and #483332
-IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
+IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango wayland" # doc profile
REQUIRED_USE="
wayland? ( gles2 )
|| ( gles2 opengl )
@@ -52,9 +52,6 @@ DEPEND="${COMMON_DEPEND}
>=dev-util/gtk-doc-am-1.13
>=sys-devel/gettext-0.19
virtual/pkgconfig
- test? (
- app-eselect/eselect-opengl
- media-libs/mesa[classic] )
"
# Need classic mesa swrast for tests, llvmpipe causes a test failure
@@ -66,14 +63,14 @@ src_prepare() {
sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
-i Makefile.am Makefile.in || die
- if ! use test ; then
- # For some reason the configure switch will not completely disable
- # tests being built
- sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
- -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
- -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
- -i Makefile.am Makefile.in || die
- fi
+ #if ! use test ; then
+ # For some reason the configure switch will not completely disable
+ # tests being built
+ sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
+ -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
+ -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ #fi
gnome2_src_prepare
}
@@ -101,25 +98,13 @@ src_configure() {
$(use_enable introspection) \
$(use_enable kms kms-egl-platform) \
$(use_enable pango cogl-pango) \
- $(use_enable test unit-tests) \
+ --disable-unit-tests \
$(use_enable wayland wayland-egl-platform) \
$(use_enable wayland wayland-egl-server) \
--disable-profile
# $(use_enable profile)
}
-src_test() {
- # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
- # NOTE: recheck if this is needed after every mesa bump
- if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
- ewarn "Skipping tests because a binary OpenGL library is enabled. To"
- ewarn "run tests for ${PN}, you need to enable the Mesa library:"
- ewarn "# eselect opengl set xorg-x11"
- return
- fi
- virtx emake check LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa"
-}
-
src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples