summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/faad2/faad2-2.10.1.ebuild')
-rw-r--r--media-libs/faad2/faad2-2.10.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/media-libs/faad2/faad2-2.10.1.ebuild b/media-libs/faad2/faad2-2.10.1.ebuild
deleted file mode 100644
index 9005b046c9c9..000000000000
--- a/media-libs/faad2/faad2-2.10.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="AAC audio decoding library"
-HOMEPAGE="https://www.audiocoding.com/faad2.html https://github.com/knik0/faad2/"
-SRC_URI="https://github.com/knik0/faad2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="digitalradio static-libs"
-
-RDEPEND=""
-DEPEND=""
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-src_prepare() {
- default
-
- sed -i -e 's:iquote :I:' libfaad/Makefile.am || die
-
- eautoreconf
-
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local myconf=(
- --without-xmms
- $(use_with digitalradio drm)
- $(use_enable static-libs static)
- )
-
- econf "${myconf[@]}"
-
- # do not build the frontend for non default abis
- if [ "${ABI}" != "${DEFAULT_ABI}" ] ; then
- sed -i -e 's/frontend//' Makefile || die
- fi
-}
-
-multilib_src_install_all() {
- find "${ED}" -type f -name '*.la' -delete || die
- einstalldocs
-}