summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/ganv/ganv-1.4.2.ebuild')
-rw-r--r--media-libs/ganv/ganv-1.4.2.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/media-libs/ganv/ganv-1.4.2.ebuild b/media-libs/ganv/ganv-1.4.2.ebuild
index d29a09de0eea..aca1ac6f985e 100644
--- a/media-libs/ganv/ganv-1.4.2.ebuild
+++ b/media-libs/ganv/ganv-1.4.2.ebuild
@@ -5,7 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
-inherit eutils waf-utils python-any-r1
+inherit eutils flag-o-matic waf-utils python-any-r1
DESCRIPTION="A GTK+ widget for interactive graph-like environments"
HOMEPAGE="http://drobilla.net/software/ganv/"
@@ -16,22 +16,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+fdgl +graphviz introspection nls"
-RDEPEND="dev-cpp/glibmm:2
+RDEPEND="
+ dev-cpp/glibmm:2
dev-cpp/gtkmm:2.4
x11-libs/gtk+:2
graphviz? ( media-gfx/graphviz[gtk] )
- introspection? ( app-text/yelp-tools
- dev-libs/gobject-introspection[doctool] )"
+ introspection? (
+ app-text/yelp-tools
+ dev-libs/gobject-introspection:=[doctool] )
+"
DEPEND="${RDEPEND}
- nls? ( virtual/libintl )"
-
-DOCS=( AUTHORS NEWS README )
+ nls? ( virtual/libintl )
+"
src_prepare() {
epatch "${FILESDIR}"/${P}-no-fdgl.patch
}
src_configure() {
+ append-cxxflags -std=c++11
waf-utils_src_configure \
$(use graphviz || echo "--no-graphviz") \
$(use fdgl || echo "--no-fdgl") \