summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gegl')
-rw-r--r--media-libs/gegl/Manifest1
-rw-r--r--media-libs/gegl/files/gegl-0.4.8-remove-imath-version.patch33
-rw-r--r--media-libs/gegl/gegl-0.4.6-r1.ebuild189
-rw-r--r--media-libs/gegl/gegl-0.4.8.ebuild174
-rw-r--r--media-libs/gegl/gegl-9999.ebuild160
5 files changed, 475 insertions, 82 deletions
diff --git a/media-libs/gegl/Manifest b/media-libs/gegl/Manifest
index c37c0e086870..13739affc932 100644
--- a/media-libs/gegl/Manifest
+++ b/media-libs/gegl/Manifest
@@ -7,3 +7,4 @@ DIST gegl-0.4.0.tar.bz2 6762190 BLAKE2B c138ee79806178f60eab2fae492fcf441dc49b54
DIST gegl-0.4.2.tar.bz2 6781136 BLAKE2B 522d4e7b2ace519423a66b7e65faab49bd0740173be6a8e108ec95b65c0359937df7b142e0a68589a4d773b839689ad6cf2ee67c5ea5b89267d46199b23e3f15 SHA512 8d842f5e192d279529615e09da8a76b051baa9c257ac699eba5f8ce46b4511554949e35f494e99c190b1477a700e018e2243a9e84c3c79e331824ca364b6cefd
DIST gegl-0.4.4.tar.bz2 6817195 BLAKE2B 928e91e61bfee8b9954992e1ad4dbc874a5f53ef5a8274a6805b2c7d9bb007e3ff9ab5e8fc0a767f7e7d05c327581231b42eebcc6f9781f9feb5abe17c22bbdf SHA512 6953bf7df225914ce9c8166f5a0490615664c69d5a66cf8ca805f75cfbe272186c7745d273fcde29c685e22a66d4483dbdf45064ec9c0007fd6d0b8aa3ebb164
DIST gegl-0.4.6.tar.bz2 6931774 BLAKE2B c8fabc8efbcc21a3663c8a3a698e6bc072506a66a21b81e6696c37c81aec1458c695f773c554b6d98c2fd21a3d3ab7fcca4b2f6567ec9d4f94b1e925b9bc9ce5 SHA512 6df34b6e76318a375820bccac6efeb2792c737e47154902fcc08ef93cb45b978992ee263260c99f8e865964d80cd1fac6dc2d6c8e4453174df64a9044b57325e
+DIST gegl-0.4.8.tar.bz2 7017022 BLAKE2B ec934fe6faa0c9328ae8c6476e19e175a8e8082e3d1f59052fb83fad766030ede9dd3464a215d332238277492151d988b17c6d3ac87f3d9cec01797acd259fae SHA512 20d2700cc74bce02e3e1b477f5e4dbd6546bb74625de235baaaa31e24f506930927af53de3d0880c0b16f93a10cec993c58a12adba59dec7dda0e389261799aa
diff --git a/media-libs/gegl/files/gegl-0.4.8-remove-imath-version.patch b/media-libs/gegl/files/gegl-0.4.8-remove-imath-version.patch
new file mode 100644
index 000000000000..54ee791a68ec
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.4.8-remove-imath-version.patch
@@ -0,0 +1,33 @@
+diff -urN a/operations/external/exr-save.cc b/operations/external/exr-save.cc
+--- a/operations/external/exr-save.cc 2018-07-11 23:15:19.000000000 +0100
++++ b/operations/external/exr-save.cc 2018-08-22 19:13:26.241432231 +0100
+@@ -145,10 +145,10 @@
+ &blue[0], &blue[1],
+ NULL, NULL, NULL);
+ {
+- Imf::Chromaticities c1 (Imath_2_2::V2f(red[0],red[1]),
+- Imath_2_2::V2f(green[0],green[1]),
+- Imath_2_2::V2f(blue[0],blue[1]),
+- Imath_2_2::V2f(wp[0],wp[1]));
++ Imf::Chromaticities c1 (Imath::V2f(red[0],red[1]),
++ Imath::V2f(green[0],green[1]),
++ Imath::V2f(blue[0],blue[1]),
++ Imath::V2f(wp[0],wp[1]));
+ Imf::addChromaticities (header, c1);
+ }
+ }
+@@ -184,10 +184,10 @@
+ &green[0], &green[1],
+ &blue[0], &blue[1],
+ NULL, NULL, NULL);
+- Imf::Chromaticities c1 (Imath_2_2::V2f(red[0],red[1]),
+- Imath_2_2::V2f(green[0],green[1]),
+- Imath_2_2::V2f(blue[0],blue[1]),
+- Imath_2_2::V2f(wp[0],wp[1]));
++ Imf::Chromaticities c1 (Imath::V2f(red[0],red[1]),
++ Imath::V2f(green[0],green[1]),
++ Imath::V2f(blue[0],blue[1]),
++ Imath::V2f(wp[0],wp[1]));
+ Imf::addChromaticities (header, c1);
+ }
+
diff --git a/media-libs/gegl/gegl-0.4.6-r1.ebuild b/media-libs/gegl/gegl-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..0334bc1b3cd5
--- /dev/null
+++ b/media-libs/gegl/gegl-0.4.6-r1.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+# vala and introspection support is broken, bug #468208
+VALA_USE_DEPEND=vapigen
+
+inherit autotools gnome2-utils python-any-r1 vala
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.gnome.org/gegl"
+ SRC_URI=""
+else
+ SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A graph based image processing framework"
+HOMEPAGE="http://www.gegl.org/"
+
+LICENSE="|| ( GPL-3+ LGPL-3 )"
+SLOT="0.4"
+
+IUSE="cairo cpu_flags_x86_mmx cpu_flags_x86_sse debug ffmpeg +introspection jpeg2k lcms lensfun openexr raw sdl svg test tiff umfpack vala v4l webp"
+REQUIRED_USE="
+ svg? ( cairo )
+ vala? ( introspection )
+"
+
+# NOTE: Even current libav 11.4 does not have AV_CODEC_CAP_VARIABLE_FRAME_SIZE
+# so there is no chance to support libav right now (Gentoo bug #567638)
+# If it returns, please check prior GEGL ebuilds for how libav was integrated. Thanks!
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ dev-libs/json-glib
+ >=media-libs/babl-0.1.54
+ sys-libs/zlib
+ >=x11-libs/gdk-pixbuf-2.32:2
+ x11-libs/pango
+
+ cairo? ( >=x11-libs/cairo-1.12.2 )
+ ffmpeg? (
+ >=media-video/ffmpeg-2.8:0=
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ virtual/jpeg:0=
+ jpeg2k? ( >=media-libs/jasper-1.900.1:= )
+ lcms? ( >=media-libs/lcms-2.8:2 )
+ lensfun? ( >=media-libs/lensfun-0.2.5 )
+ openexr? ( =media-libs/openexr-2.2*:= )
+ >=media-libs/libpng-1.6.0:0=
+ raw? ( >=media-libs/libraw-0.15.4:0= )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ svg? ( >=gnome-base/librsvg-2.40.6:2 )
+ tiff? ( >=media-libs/tiff-4:0 )
+ umfpack? ( sci-libs/umfpack )
+ v4l? ( >=media-libs/libv4l-1.0.1 )
+ webp? ( >=media-libs/libwebp-0.5.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1
+ >=sys-devel/gettext-0.19.8
+ dev-lang/perl
+ virtual/pkgconfig
+ >=sys-devel/libtool-2.2
+ test? ( ffmpeg? ( media-libs/gexiv2 )
+ introspection? (
+ $(python_gen_any_dep '>=dev-python/pygobject-3.2[${PYTHON_USEDEP}]') ) )
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use test && use introspection && python-any-r1_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.12-failing-tests.patch
+)
+
+src_prepare() {
+ default
+
+ # FIXME: the following should be proper patch sent to upstream
+ # fix OSX loadable module filename extension
+ sed -i -e 's/\.dylib/.bundle/' configure.ac || die
+ # don't require Apple's OpenCL on versions of OSX that don't have it
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -le 9 ]] ; then
+ sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
+ fi
+
+ # commit 7c78497b : tests that use gegl.png are broken on non-amd64
+ sed -e '/clones.xml/d' \
+ -e '/composite-transform.xml/d' \
+ -i tests/compositions/Makefile.am || die
+
+ eautoreconf
+
+ gnome2_environment_reset
+
+ use vala && vala_src_prepare
+}
+
+_use_with_both() {
+ if use "$1" && use "$2"; then
+ echo "--with-$3"
+ else
+ echo "--without-$3"
+ fi
+}
+
+src_configure() {
+ # never enable altering of CFLAGS via profile option
+ # libspiro: not in portage main tree
+ # disable documentation as the generating is bit automagic
+ # if anyone wants to work on it just create bug with patch
+
+ # Also please note that:
+ #
+ # - Some auto-detections are not patched away since the docs are
+ # not built (--disable-docs, lack of --enable-gtk-doc) and these
+ # tools affect re-generation of docs, only
+ # (e.g. ruby, asciidoc, dot (of graphviz), enscript)
+ #
+ # - Parameter --with-exiv2 compiles a noinst-app only, no use
+ # but needed during testing
+ #
+ # - Parameter --disable-workshop disables any use of Lua, effectivly
+ #
+ # - v4l support does not work with our media-libs/libv4l-0.8.9,
+ # upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
+ #
+ # - There are two checks for dot, one controllable by --with(out)-graphviz
+ # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
+ #
+ # - mrg is not in tree and gexiv2 support only has effect when mrg support
+ # is enabled
+ #
+ # So that's why USE="exif graphviz lua v4l" got resolved. More at:
+ # https://bugs.gentoo.org/show_bug.cgi?id=451136
+ #
+ econf \
+ --disable-docs \
+ --disable-profile \
+ --disable-silent-rules \
+ --disable-workshop \
+ --program-suffix=-${SLOT} \
+ --with-gdk-pixbuf \
+ --with-pango \
+ --without-libspiro \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable debug) \
+ $(use_with cairo) \
+ $(use_with cairo pangocairo) \
+ --without-exiv2 \
+ $(use_with ffmpeg libavformat) \
+ $(_use_with_both ffmpeg test gexiv2) \
+ --without-graphviz \
+ $(use_with jpeg2k jasper) \
+ $(use_with lcms) \
+ $(use_with lensfun) \
+ --without-lua \
+ --without-mrg \
+ $(use_with openexr) \
+ $(use_with raw libraw) \
+ $(use_with sdl) \
+ $(use_with svg librsvg) \
+ $(use_with tiff libtiff) \
+ $(use_with umfpack) \
+ $(use_with v4l libv4l) \
+ $(use_with v4l libv4l2) \
+ $(use_enable introspection) \
+ $(use_with vala) \
+ $(use_with webp)
+}
+
+src_compile() {
+ default
+
+ [[ ${PV} == *9999* ]] && emake ./ChangeLog # "./" prevents "Circular ChangeLog <- ChangeLog dependency dropped."
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/gegl/gegl-0.4.8.ebuild b/media-libs/gegl/gegl-0.4.8.ebuild
new file mode 100644
index 000000000000..92178abdfdf8
--- /dev/null
+++ b/media-libs/gegl/gegl-0.4.8.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+# vala and introspection support is broken, bug #468208
+VALA_USE_DEPEND=vapigen
+
+inherit autotools gnome2-utils python-any-r1 vala
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.gnome.org/gegl"
+ SRC_URI=""
+else
+ SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A graph based image processing framework"
+HOMEPAGE="http://www.gegl.org/"
+
+LICENSE="|| ( GPL-3+ LGPL-3 )"
+SLOT="0.4"
+
+IUSE="cairo cpu_flags_x86_mmx cpu_flags_x86_sse debug ffmpeg +introspection jpeg2k lcms lensfun libav openexr raw sdl svg test tiff umfpack vala v4l webp"
+REQUIRED_USE="
+ svg? ( cairo )
+ vala? ( introspection )
+"
+
+# NOTE: Even current libav 11.4 does not have AV_CODEC_CAP_VARIABLE_FRAME_SIZE
+# so there is no chance to support libav right now (Gentoo bug #567638)
+# If it returns, please check prior GEGL ebuilds for how libav was integrated. Thanks!
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ dev-libs/json-glib
+ >=media-libs/babl-0.1.54
+ >=media-libs/libpng-1.6.0:0=
+ sys-libs/zlib
+ virtual/jpeg:0=
+ >=x11-libs/gdk-pixbuf-2.32:2
+ x11-libs/pango
+ cairo? ( >=x11-libs/cairo-1.12.2 )
+ ffmpeg? (
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ jpeg2k? ( >=media-libs/jasper-1.900.1:= )
+ lcms? ( >=media-libs/lcms-2.8:2 )
+ lensfun? ( >=media-libs/lensfun-0.2.5 )
+ openexr? ( >=media-libs/openexr-2.2.0:= )
+ raw? ( >=media-libs/libraw-0.15.4:0= )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ svg? ( >=gnome-base/librsvg-2.40.6:2 )
+ tiff? ( >=media-libs/tiff-4:0 )
+ umfpack? ( sci-libs/umfpack )
+ v4l? ( >=media-libs/libv4l-1.0.1 )
+ webp? ( >=media-libs/libwebp-0.5.0:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-util/gtk-doc-am-1
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-devel/libtool-2.2
+ test? ( ffmpeg? ( media-libs/gexiv2 )
+ introspection? (
+ $(python_gen_any_dep '>=dev-python/pygobject-3.2[${PYTHON_USEDEP}]')
+ )
+ )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.12-failing-tests.patch"
+ "${FILESDIR}/${P}-remove-imath-version.patch"
+)
+
+pkg_setup() {
+ use test && use introspection && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # FIXME: the following should be proper patch sent to upstream
+ # fix OSX loadable module filename extension
+ sed -i -e 's/\.dylib/.bundle/' configure.ac || die
+ # don't require Apple's OpenCL on versions of OSX that don't have it
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -le 9 ]] ; then
+ sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
+ fi
+
+ # commit 7c78497b : tests that use gegl.png are broken on non-amd64
+ sed -e '/clones.xml/d' \
+ -e '/composite-transform.xml/d' \
+ -i tests/compositions/Makefile.am || die
+
+ eautoreconf
+
+ gnome2_environment_reset
+
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ # disable documentation as the generating is bit automagic
+ # if anyone wants to work on it just create bug with patch
+ --disable-docs
+ # never enable altering of CFLAGS via profile option
+ --disable-profile
+ --disable-silent-rules
+ # - Parameter --disable-workshop disables any use of Lua, effectivly
+ --disable-workshop
+ --program-suffix=-${SLOT}
+ --with-gdk-pixbuf
+ --with-pango
+ # - Parameter --with-exiv2 compiles a noinst-app only, no use
+ # but needed during testing
+ --without-exiv2
+ # - There are two checks for dot, one controllable by --with(out)-graphviz
+ # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
+ --without-graphviz
+ # libspiro: not in portage main tree
+ --without-libspiro
+ --without-lua
+ --without-mrg
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable debug)
+ $(use_enable introspection)
+ $(use_with cairo)
+ $(use_with cairo pangocairo)
+ $(use_with ffmpeg libavformat)
+ $(use_with jpeg2k jasper)
+ $(use_with lcms)
+ $(use_with lensfun)
+ $(use_with openexr)
+ $(use_with raw libraw)
+ $(use_with sdl)
+ $(use_with svg librsvg)
+ $(use_with tiff libtiff)
+ $(use_with umfpack)
+ # - v4l support does not work with our media-libs/libv4l-0.8.9,
+ # upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
+ $(use_with v4l libv4l)
+ $(use_with v4l libv4l2)
+ $(use_with vala)
+ $(use_with webp)
+ )
+
+ if use test; then
+ myeconfargs+=( $(use_with ffmpeg gexiv2) )
+ else
+ myeconfargs+=( --without-gexiv2 )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ [[ ${PV} == *9999* ]] && emake ./ChangeLog # "./" prevents "Circular ChangeLog <- ChangeLog dependency dropped."
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-libs/gegl/gegl-9999.ebuild b/media-libs/gegl/gegl-9999.ebuild
index 5fe47759f341..07ea6ab51464 100644
--- a/media-libs/gegl/gegl-9999.ebuild
+++ b/media-libs/gegl/gegl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,21 +7,21 @@ PYTHON_COMPAT=( python2_7 )
# vala and introspection support is broken, bug #468208
VALA_USE_DEPEND=vapigen
-inherit versionator gnome2-utils eutils autotools python-any-r1 vala
+inherit autotools gnome2-utils python-any-r1 vala
if [[ ${PV} == *9999* ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="git://git.gnome.org/gegl"
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gegl.git"
SRC_URI=""
else
SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="A graph based image processing framework"
HOMEPAGE="http://www.gegl.org/"
-LICENSE="|| ( GPL-3 LGPL-3 )"
+LICENSE="|| ( GPL-3+ LGPL-3 )"
SLOT="0.4"
IUSE="cairo cpu_flags_x86_mmx cpu_flags_x86_sse debug ffmpeg +introspection jpeg2k lcms lensfun libav openexr raw sdl svg test tiff umfpack vala v4l webp"
@@ -30,42 +30,47 @@ REQUIRED_USE="
vala? ( introspection )
"
+# NOTE: Even current libav 11.4 does not have AV_CODEC_CAP_VARIABLE_FRAME_SIZE
+# so there is no chance to support libav right now (Gentoo bug #567638)
+# If it returns, please check prior GEGL ebuilds for how libav was integrated. Thanks!
RDEPEND="
>=dev-libs/glib-2.44:2
dev-libs/json-glib
- >=media-libs/babl-0.1.30
+ >=media-libs/babl-0.1.54
+ >=media-libs/libpng-1.6.0:0=
sys-libs/zlib
+ virtual/jpeg:0=
>=x11-libs/gdk-pixbuf-2.32:2
x11-libs/pango
-
- cairo? ( x11-libs/cairo )
+ cairo? ( >=x11-libs/cairo-1.12.2 )
ffmpeg? (
libav? ( media-video/libav:0= )
!libav? ( media-video/ffmpeg:0= )
)
introspection? ( >=dev-libs/gobject-introspection-1.32:= )
- virtual/jpeg:0=
jpeg2k? ( >=media-libs/jasper-1.900.1:= )
- lcms? ( >=media-libs/lcms-2.2:2 )
+ lcms? ( >=media-libs/lcms-2.8:2 )
lensfun? ( >=media-libs/lensfun-0.2.5 )
- openexr? ( media-libs/openexr:= )
- media-libs/libpng:0=
+ openexr? ( >=media-libs/openexr-2.2.0:= )
raw? ( >=media-libs/libraw-0.15.4:0= )
- sdl? ( media-libs/libsdl )
- svg? ( >=gnome-base/librsvg-2.14:2 )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ svg? ( >=gnome-base/librsvg-2.40.6:2 )
tiff? ( >=media-libs/tiff-4:0 )
umfpack? ( sci-libs/umfpack )
v4l? ( >=media-libs/libv4l-1.0.1 )
- webp? ( media-libs/libwebp )
+ webp? ( >=media-libs/libwebp-0.5.0:= )
"
DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1
- >=dev-util/intltool-0.40.1
dev-lang/perl
+ >=dev-util/gtk-doc-am-1
+ >=sys-devel/gettext-0.19.8
virtual/pkgconfig
>=sys-devel/libtool-2.2
- test? ( introspection? (
- $(python_gen_any_dep '>=dev-python/pygobject-3.2[${PYTHON_USEDEP}]') ) )
+ test? ( ffmpeg? ( media-libs/gexiv2 )
+ introspection? (
+ $(python_gen_any_dep '>=dev-python/pygobject-3.2[${PYTHON_USEDEP}]')
+ )
+ )
vala? ( $(vala_depend) )
"
@@ -97,68 +102,59 @@ src_prepare() {
}
src_configure() {
- # never enable altering of CFLAGS via profile option
- # libspiro: not in portage main tree
- # disable documentation as the generating is bit automagic
- # if anyone wants to work on it just create bug with patch
-
- # Also please note that:
- #
- # - Some auto-detections are not patched away since the docs are
- # not built (--disable-docs, lack of --enable-gtk-doc) and these
- # tools affect re-generation of docs, only
- # (e.g. ruby, asciidoc, dot (of graphviz), enscript)
- #
- # - Parameter --with-exiv2 compiles a noinst-app only, no use
- #
- # - Parameter --disable-workshop disables any use of Lua, effectivly
- #
- # - v4l support does not work with our media-libs/libv4l-0.8.9,
- # upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
- #
- # - There are two checks for dot, one controllable by --with(out)-graphviz
- # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
- #
- # - mrg is not in tree and gexiv2 support only has effect when mrg support
- # is enabled
- #
- # So that's why USE="exif graphviz lua v4l" got resolved. More at:
- # https://bugs.gentoo.org/show_bug.cgi?id=451136
- #
- econf \
- --disable-docs \
- --disable-profile \
- --disable-silent-rules \
- --disable-workshop \
- --program-suffix=-${SLOT} \
- --with-gdk-pixbuf \
- --with-pango \
- --without-libspiro \
- $(use_enable cpu_flags_x86_mmx mmx) \
- $(use_enable cpu_flags_x86_sse sse) \
- $(use_enable debug) \
- $(use_with cairo) \
- $(use_with cairo pangocairo) \
- --without-exiv2 \
- $(use_with ffmpeg libavformat) \
- --without-gexiv2 \
- --without-graphviz \
- $(use_with jpeg2k jasper) \
- $(use_with lcms) \
- $(use_with lensfun) \
- --without-lua \
- --without-mrg \
- $(use_with openexr) \
- $(use_with raw libraw) \
- $(use_with sdl) \
- $(use_with svg librsvg) \
- $(use_with tiff libtiff) \
- $(use_with umfpack) \
- $(use_with v4l libv4l) \
- $(use_with v4l libv4l2) \
- $(use_enable introspection) \
- $(use_with vala) \
+ local myeconfargs=(
+ # disable documentation as the generating is bit automagic
+ # if anyone wants to work on it just create bug with patch
+ --disable-docs
+ # never enable altering of CFLAGS via profile option
+ --disable-profile
+ --disable-silent-rules
+ # - Parameter --disable-workshop disables any use of Lua, effectivly
+ --disable-workshop
+ --program-suffix=-${SLOT}
+ --with-gdk-pixbuf
+ --with-pango
+ # - Parameter --with-exiv2 compiles a noinst-app only, no use
+ # but needed during testing
+ --without-exiv2
+ # - There are two checks for dot, one controllable by --with(out)-graphviz
+ # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
+ --without-graphviz
+ # libspiro: not in portage main tree
+ --without-libspiro
+ --without-lua
+ --without-mrg
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable debug)
+ $(use_enable introspection)
+ $(use_with cairo)
+ $(use_with cairo pangocairo)
+ $(use_with ffmpeg libavformat)
+ $(use_with jpeg2k jasper)
+ $(use_with lcms)
+ $(use_with lensfun)
+ $(use_with openexr)
+ $(use_with raw libraw)
+ $(use_with sdl)
+ $(use_with svg librsvg)
+ $(use_with tiff libtiff)
+ $(use_with umfpack)
+ # - v4l support does not work with our media-libs/libv4l-0.8.9,
+ # upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
+ $(use_with v4l libv4l)
+ $(use_with v4l libv4l2)
+ $(use_with vala)
$(use_with webp)
+ )
+
+ if use test; then
+ myeconfargs+=( $(use_with ffmpeg gexiv2) )
+ else
+ myeconfargs+=( "--without-gexiv2" )
+ fi
+
+ econf "${myeconfargs[@]}"
}
src_compile() {
@@ -169,5 +165,5 @@ src_compile() {
src_install() {
default
- prune_libtool_files --all
+ find "${ED}" -name '*.la' -delete || die
}