summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gmmlib/gmmlib-9999.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/media-libs/gmmlib/gmmlib-9999.ebuild b/media-libs/gmmlib/gmmlib-9999.ebuild
index 1f972c3b1914..2a09f24b8f3d 100644
--- a/media-libs/gmmlib/gmmlib-9999.ebuild
+++ b/media-libs/gmmlib/gmmlib-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake-multilib
if [[ ${PV} == *9999 ]] ; then
: ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
@@ -11,27 +11,29 @@ if [[ ${PV} == *9999 ]] ; then
: ${EGIT_BRANCH:="release/${PV%.9999}"}
fi
inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
+ S="${WORKDIR}/${PN}-intel-${P}"
fi
DESCRIPTION="Intel Graphics Memory Management Library"
HOMEPAGE="https://github.com/intel/gmmlib"
-SRC_URI=""
LICENSE="MIT"
-SLOT="0"
-IUSE="test +custom-cflags"
+SLOT="0/12.3"
+IUSE="+custom-cflags test"
RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
- "${FILESDIR}"/${PN}-20.4.1_custom_cflags.patch
"${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
+ "${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
)
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING="$(usex test)"
- -DBUILD_TYPE="Release"
-DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
)