summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.12.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index 9847a2829c5f..006274e62a46 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -1,3 +1,4 @@
DIST gst-plugins-good-0.10.31.tar.xz 2738016 SHA256 77a8436a7c0a15f876bad29616835046890df2bcaf72da02151bd91e3d292b64 SHA512 d153dcd5bb846450e9d76fe247f2b2e627e760feaad1bfd4c503a39af2128fad3630788463ea0d50539209236c864df0b2172ab9dac52f49cadff69ac7346809 WHIRLPOOL 952f65219d9e9645c9ab89b071c56d783e2c795fadbf59176e430ba86a5fcaeb6bfc93f0978d424158550a4526145b5567acf2ff1d59e0068241821d332fd3c9
DIST gst-plugins-good-1.10.3.tar.xz 3426164 SHA256 4e07e93e34d4b93208f1579c21e7d91a236577b36f128a5332ffee85b4465955 SHA512 ae1523e374715b4f65509eb63d987118510fc4fe61b5ac2a98e4ec06feb2ec65899557976d796ea09644b32652f3a321aca462b8fe1621308e0c00dd6913e592 WHIRLPOOL 7c2c5fa9b21cfd35e7895beb947b6396ae55bd2f510fbe55b7696a0b68e7248e0cb04d5e4fe55e8d029ab03b5401fe20c5080a92b0b22532c9ac3dcb7167681f
DIST gst-plugins-good-1.10.5.tar.xz 3425088 SHA256 be053f6ed716eeb517cec148cec637cdce571c6e04d5c21409e2876fb76c7639 SHA512 556bb5f95f3d52722849b5abf2ece1abeba9eae556aa2bebccaeda419639aa93b517bacbe74a0b3c0ce481d1e56ed2793de892a3054fdb06ec9652e207d69e16 WHIRLPOOL 01405868de1faee643f1b9653efaf0a822a85a02d6c04ff98b93e9dc8339671111005105aeb4cb2d5b6c86e69c943d12daff6fc35e94c002b12e805f9605eac6
+DIST gst-plugins-good-1.12.2.tar.xz 3490976 SHA256 5591ee7208ab30289a30658a82b76bf87169c927572d9b794f3a41ed48e1ee96 SHA512 b83d63cf169521975e1358ca7ebe406392c887956a2f422813b7324c385bae058dc6797e1f2200294f9846ad831ce16650090f2acf946100b9a1d36963b4f163 WHIRLPOOL 0c7f4156b43cc52dc3341ac4ff3bae9e180806fd20d06ce382650f9426e9b3dd01d208d3b859d7a98410098a9e071a148dac4cbcc93ebf46fd6b453c3bd454f2
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.12.2.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.12.2.ebuild
new file mode 100644
index 000000000000..e1da23e75e6b
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.12.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}