summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.0.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.0.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.0.ebuild
new file mode 100644
index 000000000000..69bb42e0936e
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-1.6:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-1.6:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}