summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/ilmbase/ilmbase-2.2.0.ebuild')
-rw-r--r--media-libs/ilmbase/ilmbase-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/ilmbase/ilmbase-2.2.0.ebuild b/media-libs/ilmbase/ilmbase-2.2.0.ebuild
new file mode 100644
index 000000000000..1c6485d13acb
--- /dev/null
+++ b/media-libs/ilmbase/ilmbase-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-multilib
+
+DESCRIPTION="OpenEXR ILM Base libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="http://download.savannah.gnu.org/releases/openexr/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/12" # based on SONAME
+KEYWORDS="~amd64 -arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/OpenEXR/IlmBaseConfig.h )
+
+src_configure() {
+ # Disable use of ucontext.h wrt #482890
+ if use hppa || use ppc || use ppc64; then
+ export ac_cv_header_ucontext_h=no
+ fi
+
+ autotools-multilib_src_configure
+}