summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libaom/files/libaom-3.4.0-posix-c-source-ftello.patch')
-rw-r--r--media-libs/libaom/files/libaom-3.4.0-posix-c-source-ftello.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/media-libs/libaom/files/libaom-3.4.0-posix-c-source-ftello.patch b/media-libs/libaom/files/libaom-3.4.0-posix-c-source-ftello.patch
new file mode 100644
index 000000000000..6e910b3f732c
--- /dev/null
+++ b/media-libs/libaom/files/libaom-3.4.0-posix-c-source-ftello.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/869419
+
+POSIX_C_SOURCE is needed for ftello.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -266,6 +266,7 @@ add_library(aom_rtcd OBJECT ${AOM_RTCD_SOURCES})
+ add_dependencies(aom_rtcd aom_version)
+
+ if(ENABLE_EXAMPLES)
++ add_definitions(-D_POSIX_C_SOURCE=200112L)
+ add_library(aom_encoder_stats OBJECT ${AOM_ENCODER_STATS_SOURCES})
+ set(AOM_LIB_TARGETS ${AOM_LIB_TARGETS} aom_encoder_stats)
+ endif()