summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libbdplus')
-rw-r--r--media-libs/libbdplus/Manifest1
-rw-r--r--media-libs/libbdplus/libbdplus-0.2.0.ebuild49
-rw-r--r--media-libs/libbdplus/libbdplus-9999.ebuild12
3 files changed, 57 insertions, 5 deletions
diff --git a/media-libs/libbdplus/Manifest b/media-libs/libbdplus/Manifest
index 1a3d37fd9857..15a53cb7b585 100644
--- a/media-libs/libbdplus/Manifest
+++ b/media-libs/libbdplus/Manifest
@@ -1 +1,2 @@
DIST libbdplus-0.1.2.tar.bz2 319828 BLAKE2B bdf8868dc511b22fd6926b4b29cfae513ca5c9f30433314c99bf31aefb5842eea1042e514383d1c1ff96ee6c62f3220a542973eb1017df8dd48aecd7f81237ac SHA512 e00e7bc9f52b9275646593b753ba646b052255be94a7241965f4dbe4734f8f6a072973ed4b9997957f939236b0633897c295749f79e232188430795be5b5087b
+DIST libbdplus-0.2.0.tar.bz2 321743 BLAKE2B 2ef8da1741829aef1e0e52fda3ef4d41d05fc7141d1e38c0e8bbdf116fe7afa65024c9d97f61e5ec9ccdf5d2d6063a4d1aff2a0731e7f19b280e31f1b637a9c2 SHA512 172e4932fb5540fbdb5b86e1d42cfaddf60b81416d2de50c8add83fb7f1bd7c296c975fd84a6ec42566977086dccfe07db5ce696038862bc75c6494c647998d6
diff --git a/media-libs/libbdplus/libbdplus-0.2.0.ebuild b/media-libs/libbdplus/libbdplus-0.2.0.ebuild
new file mode 100644
index 000000000000..42d90708b4cc
--- /dev/null
+++ b/media-libs/libbdplus/libbdplus-0.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://code.videolan.org/videolan/libbdplus.git"
+else
+ SRC_URI="https://downloads.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Blu-ray library for BD+ decryption"
+HOMEPAGE="https://www.videolan.org/developers/libbdplus.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="aacs"
+
+RDEPEND="
+ dev-libs/libgcrypt:=[${MULTILIB_USEDEP}]
+ dev-libs/libgpg-error[${MULTILIB_USEDEP}]
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ $(use_with aacs libaacs)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/media-libs/libbdplus/libbdplus-9999.ebuild b/media-libs/libbdplus/libbdplus-9999.ebuild
index 8bffc8107314..42d90708b4cc 100644
--- a/media-libs/libbdplus/libbdplus-9999.ebuild
+++ b/media-libs/libbdplus/libbdplus-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib-minimal
@@ -21,7 +21,7 @@ SLOT="0"
IUSE="aacs"
RDEPEND="
- dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+ dev-libs/libgcrypt:=[${MULTILIB_USEDEP}]
dev-libs/libgpg-error[${MULTILIB_USEDEP}]
aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )
"
@@ -29,19 +29,21 @@ DEPEND="${RDEPEND}"
src_prepare() {
default
+
[[ ${PV} == 9999 ]] && eautoreconf
}
multilib_src_configure() {
local myeconfargs=(
--disable-optimizations
- --disable-static
$(use_with aacs libaacs)
)
- ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
einstalldocs
+
find "${ED}" -type f -name "*.la" -delete || die
}