summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libde265/libde265-1.0.2.ebuild')
-rw-r--r--media-libs/libde265/libde265-1.0.2.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/media-libs/libde265/libde265-1.0.2.ebuild b/media-libs/libde265/libde265-1.0.2.ebuild
index 13bc0edd3cf4..59318a1ef2cd 100644
--- a/media-libs/libde265/libde265-1.0.2.ebuild
+++ b/media-libs/libde265/libde265-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,18 +14,19 @@ SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="debug qt4 qt5 static-libs cpu_flags_x86_sse tools"
+IUSE="debug qt5 static-libs cpu_flags_x86_sse"
DEPEND="
- qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 )
- qt5? ( dev-qt/qtgui:5 dev-qt/qtcore:5 dev-qt/qtwidgets:5 )
media-libs/libsdl
virtual/ffmpeg
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
"
RDEPEND="${DEPEND}"
-REQUIRED_USE="tools? ( || ( qt4 qt5 ) )"
-
src_prepare() {
sed -ri 's/(PIX_FMT_)/AV_\1/g' sherlock265/VideoDecoder.cc || die
autotools-multilib_src_prepare
@@ -38,8 +39,8 @@ src_configure() {
$(use_enable debug log-info)
$(use_enable debug log-debug)
$(use_enable debug log-trace)
- $(use_enable tools dec265)
- $(use_enable tools sherlock265)
+ $(use_enable qt5 dec265)
+ $(use_enable qt5 sherlock265)
--disable-silent-rules
--enable-log-error
)