summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libde265/libde265-9999.ebuild')
-rw-r--r--media-libs/libde265/libde265-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/media-libs/libde265/libde265-9999.ebuild b/media-libs/libde265/libde265-9999.ebuild
index 29c28d991c82..ca34a4a3dccb 100644
--- a/media-libs/libde265/libde265-9999.ebuild
+++ b/media-libs/libde265/libde265-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools multilib-minimal
@@ -9,8 +9,8 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://github.com/strukturag/libde265/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi
DESCRIPTION="Open h.265 video codec implementation"
@@ -56,7 +56,6 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
- --disable-static
--enable-log-error
ax_cv_check_cflags___msse4_1=$(usex cpu_flags_x86_sse4_1)
ax_cv_check_cflags___mfpu_neon=$(usex cpu_flags_arm_neon)