summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libde265')
-rw-r--r--media-libs/libde265/Manifest1
-rw-r--r--media-libs/libde265/files/libde265-1.0.2-qtbindir.patch47
-rw-r--r--media-libs/libde265/libde265-1.0.2.ebuild50
3 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/libde265/Manifest b/media-libs/libde265/Manifest
index e40b275b4d49..7b7d128f6e52 100644
--- a/media-libs/libde265/Manifest
+++ b/media-libs/libde265/Manifest
@@ -1 +1,2 @@
+DIST libde265-1.0.2.tar.gz 381737 BLAKE2B cea70a46193e4cb4a0beb1d0a86af17df13e70602c16c509b85acb918c0ddbdfa3e60bfa2b83922200fd9b1465c18edf20fe0939d7f78f3865a9d54b144de90b SHA512 714ce93f204bd034e3cccd9624d32ea6fcb31be25dbfd1a85f91814b33a01cc1515a3887a1ccabb9f0986686ecbcdd984b88e605190ff33d2bd75cc3b9f4bdd3
DIST libde265-1.0.3.tar.gz 399996 BLAKE2B 988b21085f82d3b33b0480542677be96db5219c1b767aae3674f89862fdaf3355dcfea3fa99699798a4fcc6b72a63a3a6f61a3fd8d2ea8483231205cd6d87175 SHA512 0153632afcc9733950e8354997ccd93eddad90e8e0f7362bfe49b93b11cb1756cf803d0ba5c07042aee80e18227613af768ca82baf7891c687edf5e253a129c4
diff --git a/media-libs/libde265/files/libde265-1.0.2-qtbindir.patch b/media-libs/libde265/files/libde265-1.0.2-qtbindir.patch
new file mode 100644
index 000000000000..e73d43b52744
--- /dev/null
+++ b/media-libs/libde265/files/libde265-1.0.2-qtbindir.patch
@@ -0,0 +1,47 @@
+From 88924722c0e25566953276c52df7ef5040714cc5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Tue, 5 Dec 2017 01:19:53 +0100
+Subject: [PATCH] Fix Qt5 moc detection, throw away Qt4
+
+---
+ configure.ac | 24 ++++++------------------
+ 1 file changed, 6 insertions(+), 18 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6580963..eb4ccec 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -325,24 +325,12 @@ if eval "test $enable_sherlock265 = yes" && eval "test $have_videogfx != yes" &&
+ fi
+
+ if eval "test $enable_sherlock265 = yes" ; then
+- PKG_CHECK_MODULES([QT], [Qt5Core Qt5Gui Qt5Widgets], [found_qt=5], [found_qt=no])
+- if eval "test $found_qt = no" ; then
+- PKG_CHECK_MODULES([QT], [QtCore QtGui], [found_qt=4])
+- fi
+- AC_PATH_PROGS([QTCHOOSER],[qtchooser])
+- if eval "test x$QTCHOOSER = x" ; then
+- AC_PATH_PROGS([QTMOC],[moc-qt$found_qt moc])
+- if eval "test x$QTMOC = x" ; then
+- AC_MSG_ERROR([Need the "moc" commandline tool which is required to generate the Qt files required for sherlock265.])
+- fi
+- else
+- QTMOC="$QTCHOOSER -run-tool=moc -qt=$found_qt"
+- fi
+- AC_MSG_CHECKING([for version of $QTMOC])
+- QTMOC_VERSION=`$QTMOC -v 2>&1 | $GREP -o '[[0-9]]\+.[[0-9]]\+.[[0-9]]\+'`
+- AC_MSG_RESULT([$QTMOC_VERSION])
+- AX_COMPARE_VERSION([$QTMOC_VERSION], [lt], [$found_qt],
+- [AC_MSG_ERROR([Please install "moc" for Qt$found_qt (found $QTMOC_VERSION).])])
++ PKG_CHECK_MODULES([QT], [Qt5Core >= 5.1.0 Qt5Gui Qt5Widgets], [
++ QT_PATH="$( eval $PKG_CONFIG --variable=host_bins Qt5Core )"
++ AC_PATH_PROGS([QTMOC], [moc-qt5 moc], [moc], [$QT_PATH])
++ ], [
++ AC_MSG_ERROR([Qt5 moc not found, which is required to generate the Qt files for sherlock265.])
++ ])
+ AC_SUBST(QTMOC)
+ fi
+
+--
+2.15.1
+
diff --git a/media-libs/libde265/libde265-1.0.2.ebuild b/media-libs/libde265/libde265-1.0.2.ebuild
new file mode 100644
index 000000000000..a4b6724cc51f
--- /dev/null
+++ b/media-libs/libde265/libde265-1.0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="Open h.265 video codec implementation"
+HOMEPAGE="https://github.com/strukturag/libde265"
+SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug qt5 static-libs cpu_flags_x86_sse"
+
+DEPEND="
+ media-libs/libsdl
+ virtual/ffmpeg
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qtbindir.patch" )
+
+src_prepare() {
+ sed -ri 's/(PIX_FMT_)/AV_\1/g' sherlock265/VideoDecoder.cc || die
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable static-libs static)
+ $(use_enable debug log-info)
+ $(use_enable debug log-debug)
+ $(use_enable debug log-trace)
+ $(use_enable qt5 dec265)
+ $(use_enable qt5 sherlock265)
+ --disable-silent-rules
+ --enable-log-error
+ )
+ autotools-multilib_src_configure "${myeconfargs[@]}"
+}