summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libfreehand/libfreehand-9999.ebuild')
-rw-r--r--media-libs/libfreehand/libfreehand-9999.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/media-libs/libfreehand/libfreehand-9999.ebuild b/media-libs/libfreehand/libfreehand-9999.ebuild
index 37f65017def8..b5b9ce6d48a9 100644
--- a/media-libs/libfreehand/libfreehand-9999.ebuild
+++ b/media-libs/libfreehand/libfreehand-9999.ebuild
@@ -1,29 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit flag-o-matic
-
-if [[ ${PV} = *9999 ]]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libfreehand.git"
inherit autotools git-r3
else
SRC_URI="https://dev-www.libreoffice.org/src/libfreehand/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
+
DESCRIPTION="Library for import of FreeHand drawings"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
LICENSE="MPL-2.0"
SLOT="0"
-IUSE="doc static-libs test"
+IUSE="doc test"
RESTRICT="!test? ( test )"
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
RDEPEND="
dev-libs/librevenge
sys-libs/zlib
@@ -36,21 +31,24 @@ DEPEND="${RDEPEND}
sys-devel/libtool
test? ( dev-util/cppunit )
"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_prepare() {
default
- [[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == *9999 ]] && eautoreconf
+
+ if [[ ${PV} == *9999 ]]; then
+ mkdir -p m4 || die
+ eautoreconf
+ fi
}
src_configure() {
- # bug 619762
- append-cxxflags -std=c++14
-
local myeconfargs=(
--disable-werror
$(use_with doc docs)
- $(use_enable static-libs static)
$(use_enable test tests)
)
econf "${myeconfargs[@]}"
@@ -58,5 +56,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.la' -type f -delete || die
}