summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libltc/libltc-9999.ebuild')
-rw-r--r--media-libs/libltc/libltc-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/media-libs/libltc/libltc-9999.ebuild b/media-libs/libltc/libltc-9999.ebuild
index 37f4e75a206e..3049a511a985 100644
--- a/media-libs/libltc/libltc-9999.ebuild
+++ b/media-libs/libltc/libltc-9999.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Linear/Logitudinal Time Code (LTC) Library"
-HOMEPAGE="https://github.com/x42/libltc.git"
+HOMEPAGE="https://github.com/x42/libltc"
if [[ ${PV} == *9999 ]]; then
inherit git-r3 autotools
- EGIT_REPO_URI="https://github.com/x42/libltc.git"
+ EGIT_REPO_URI="https://github.com/x42/libltc"
else
+ inherit libtool
SRC_URI="https://github.com/x42/libltc/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -19,7 +20,11 @@ RESTRICT="mirror"
src_prepare() {
default
- [[ ${PV} == *9999 ]] && (eautoreconf || die)
+ if [[ ${PV} = *9999 ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
}
src_install() {