summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libmatroska/libmatroska-1.7.1.ebuild')
-rw-r--r--media-libs/libmatroska/libmatroska-1.7.1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/media-libs/libmatroska/libmatroska-1.7.1.ebuild b/media-libs/libmatroska/libmatroska-1.7.1.ebuild
new file mode 100644
index 000000000000..8f0389cab5b3
--- /dev/null
+++ b/media-libs/libmatroska/libmatroska-1.7.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Extensible multimedia container format based on EBML"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libmatroska/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/7" # subslot = soname major version
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~x86-linux"
+
+RDEPEND=">=dev-libs/libebml-1.4.3:="
+DEPEND="${RDEPEND}"