summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libopusenc/libopusenc-0.2.1-r1.ebuild')
-rw-r--r--media-libs/libopusenc/libopusenc-0.2.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/libopusenc/libopusenc-0.2.1-r1.ebuild b/media-libs/libopusenc/libopusenc-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..f37ab0ef5ec0
--- /dev/null
+++ b/media-libs/libopusenc/libopusenc-0.2.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="High-level API for encoding .opus files"
+HOMEPAGE="https://www.opus-codec.org/"
+SRC_URI="https://archive.mozilla.org/pub/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND=">=media-libs/opus-1.1:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.1-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Should be able to drop in next release if patches merged
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable doc)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}