summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libpqstego/libpqstego-0.0.1-r1.ebuild')
-rw-r--r--media-libs/libpqstego/libpqstego-0.0.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-libs/libpqstego/libpqstego-0.0.1-r1.ebuild b/media-libs/libpqstego/libpqstego-0.0.1-r1.ebuild
new file mode 100644
index 000000000000..343ed550a6c4
--- /dev/null
+++ b/media-libs/libpqstego/libpqstego-0.0.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library for Perturbed Quantization Steganography"
+HOMEPAGE="https://sourceforge.net/projects/pqstego/"
+SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sci-libs/gsl:=[cblas-external]"
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die "Pruning failed"
+}