summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libsoundio')
-rw-r--r--media-libs/libsoundio/files/libsoundio-1.1.0_missing_include.patch22
-rw-r--r--media-libs/libsoundio/libsoundio-1.1.0.ebuild2
2 files changed, 24 insertions, 0 deletions
diff --git a/media-libs/libsoundio/files/libsoundio-1.1.0_missing_include.patch b/media-libs/libsoundio/files/libsoundio-1.1.0_missing_include.patch
new file mode 100644
index 000000000000..4a0989525a9b
--- /dev/null
+++ b/media-libs/libsoundio/files/libsoundio-1.1.0_missing_include.patch
@@ -0,0 +1,22 @@
+From e8b908243d58760d7815525d18bddd64ec97a5d2 Mon Sep 17 00:00:00 2001
+From: Andrew Kelley <superjoe30@gmail.com>
+Date: Fri, 22 Apr 2016 10:24:32 -0700
+Subject: [PATCH] add missing include directive
+
+fixes compilation when no backends are available. closes #67
+---
+ src/soundio_private.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/soundio_private.h b/src/soundio_private.h
+index 13d1d7a..213b36f 100644
+--- a/src/soundio_private.h
++++ b/src/soundio_private.h
+@@ -10,6 +10,7 @@
+
+ #include "soundio_internal.h"
+ #include "config.h"
++#include "list.h"
+
+ #ifdef SOUNDIO_HAVE_JACK
+ #include "jack.h"
diff --git a/media-libs/libsoundio/libsoundio-1.1.0.ebuild b/media-libs/libsoundio/libsoundio-1.1.0.ebuild
index ed32c520f008..0cde6b72e9fb 100644
--- a/media-libs/libsoundio/libsoundio-1.1.0.ebuild
+++ b/media-libs/libsoundio/libsoundio-1.1.0.ebuild
@@ -19,6 +19,8 @@ DEPEND="alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}_missing_include.patch" )
+
# ENABLE_JACK does not support the current version of jack1
# See https://github.com/andrewrk/libsoundio/issues/11
multilib_src_configure() {