summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libxmp/libxmp-9999.ebuild')
-rw-r--r--media-libs/libxmp/libxmp-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libxmp/libxmp-9999.ebuild b/media-libs/libxmp/libxmp-9999.ebuild
new file mode 100644
index 000000000000..f6027f5b906c
--- /dev/null
+++ b/media-libs/libxmp/libxmp-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library that renders module files to PCM data"
+HOMEPAGE="https://github.com/libxmp/libxmp"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/libxmp/libxmp.git"
+else
+ SRC_URI="https://github.com/libxmp/${PN}/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# bzip2 depacker code is 0BSD
+LICENSE="MIT 0BSD"
+SLOT="0"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_compile() {
+ emake V=1
+}