summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mpvqt/mpvqt-1.0.0.ebuild')
-rw-r--r--media-libs/mpvqt/mpvqt-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/mpvqt/mpvqt-1.0.0.ebuild b/media-libs/mpvqt/mpvqt-1.0.0.ebuild
new file mode 100644
index 000000000000..990a449f34e3
--- /dev/null
+++ b/media-libs/mpvqt/mpvqt-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.245.0
+QTMIN=6.5.0
+inherit ecm kde.org
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="libmpv wrapper for QtQuick2 and QML"
+HOMEPAGE="https://invent.kde.org/libraries/mpvqt"
+
+LICENSE="|| ( GPL-2 GPL-3 LGPL-3 LGPL-2.1 ) CC-BY-SA-4.0 MIT BSD"
+SLOT="6"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,opengl]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ media-video/mpv:=[libmpv]
+"
+RDEPEND="${DEPEND}"