summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opencv/opencv-4.5.5.ebuild')
-rw-r--r--media-libs/opencv/opencv-4.5.5.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-libs/opencv/opencv-4.5.5.ebuild b/media-libs/opencv/opencv-4.5.5.ebuild
index cc9da840a605..7eddbcd042ce 100644
--- a/media-libs/opencv/opencv-4.5.5.ebuild
+++ b/media-libs/opencv/opencv-4.5.5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
CMAKE_ECLASS=cmake
-inherit java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
+inherit flag-o-matic java-pkg-opt-2 java-ant-2 cmake-multilib python-r1 toolchain-funcs
DESCRIPTION="A collection of algorithms and sample code for various computer vision problems"
HOMEPAGE="https://opencv.org"
@@ -303,6 +303,9 @@ pkg_setup() {
}
src_prepare() {
+ # https://bugs.gentoo.org/838274
+ replace-flags -O3 -O2
+
cmake_src_prepare
# remove bundled stuff