summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/openexr/openexr-3.2.2.ebuild')
-rw-r--r--media-libs/openexr/openexr-3.2.2.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/media-libs/openexr/openexr-3.2.2.ebuild b/media-libs/openexr/openexr-3.2.2.ebuild
index 71b9a4937dcb..84a97d580e9f 100644
--- a/media-libs/openexr/openexr-3.2.2.ebuild
+++ b/media-libs/openexr/openexr-3.2.2.ebuild
@@ -52,10 +52,6 @@ src_prepare() {
sed -e "s:if(INSTALL_DOCS):if(OPENEXR_INSTALL_DOCS):" \
-i docs/CMakeLists.txt || die
- if use x86; then
- eapply "${FILESDIR}/${PN}-3.1.5-drop-failing-testDwaLookups.patch"
- fi
-
cmake_src_prepare
if use test; then
@@ -123,6 +119,16 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ local CMAKE_SKIP_TESTS=()
+
+ use x86 && CMAKE_SKIP_TESTS+=(
+ '^OpenEXR.testDwaLookups$'
+ )
+
+ cmake_src_test
+}
+
src_install() {
use examples && docompress -x "/usr/share/doc/${PF}/examples"