summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch')
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch b/media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch
new file mode 100644
index 000000000000..0202c47d13a4
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.6.0-cudaflags.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -595,7 +595,7 @@ if(CUDA_FOUND)
+ )
+ set(OSD_GPU TRUE)
+
+- if (UNIX)
++ if (FALSE)
+ list( APPEND CUDA_NVCC_FLAGS -Xcompiler -fPIC )
+ # Use OSD_CUDA_NVCC_FLAGS to specify --gpu-architecture or other CUDA
+ # compilation options. The overrides here are only for compatibility
+@@ -609,7 +609,7 @@ if(CUDA_FOUND)
+ endif()
+ endif()
+
+- if (DEFINED OSD_CUDA_NVCC_FLAGS)
++ if (FALSE)
+ list( APPEND CUDA_NVCC_FLAGS ${OSD_CUDA_NVCC_FLAGS})
+ endif()
+