summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opusfile/opusfile-0.11.ebuild')
-rw-r--r--media-libs/opusfile/opusfile-0.11.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/opusfile/opusfile-0.11.ebuild b/media-libs/opusfile/opusfile-0.11.ebuild
new file mode 100644
index 000000000000..1c16b94fd610
--- /dev/null
+++ b/media-libs/opusfile/opusfile-0.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A high-level decoding and seeking API for .opus files"
+HOMEPAGE="https://www.opus-codec.org/"
+SRC_URI="https://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc fixed-point +float +http libressl static-libs"
+
+RDEPEND="media-libs/libogg
+ media-libs/opus
+ http? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="^^ ( fixed-point float )"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ $(use_enable doc)
+ $(use_enable fixed-point)\
+ $(use_enable float)
+ $(use_enable http)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}