summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/partio/partio-1.5.0.ebuild')
-rw-r--r--media-libs/partio/partio-1.5.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/partio/partio-1.5.0.ebuild b/media-libs/partio/partio-1.5.0.ebuild
new file mode 100644
index 000000000000..2aaed0b7b0be
--- /dev/null
+++ b/media-libs/partio/partio-1.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit cmake-utils python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wdas/partio.git"
+else
+ SRC_URI="https://github.com/wdas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A library for particle IO and manipulation"
+HOMEPAGE="https://www.disneyanimation.com/technology/partio.html"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freeglut
+ sys-libs/zlib:=
+ virtual/opengl
+"
+
+DEPEND="${RDEPEND}
+ dev-lang/swig:*
+ doc? ( app-doc/doxygen[latex] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package doc Doxygen)
+ )
+ cmake-utils_src_configure
+}