summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/phonon-gstreamer/phonon-gstreamer-4.9.90.ebuild')
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.9.90.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.90.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.90.ebuild
new file mode 100644
index 000000000000..86d0b8ffe1a6
--- /dev/null
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.90.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="GStreamer backend for the Phonon multimedia library"
+HOMEPAGE="https://phonon.kde.org/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/unstable/phonon/phonon-backend-gstreamer/phonon-backend-gstreamer-${PV}.tar.xz"
+ KEYWORDS=""
+fi
+
+LICENSE="LGPL-2.1+ || ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+IUSE="alsa debug +network"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ >=media-libs/phonon-4.10.60
+ media-plugins/gst-plugins-meta:1.0[alsa?,ogg,vorbis]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}
+ network? ( media-plugins/gst-plugins-soup:1.0 )
+"