summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch')
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch
new file mode 100644
index 000000000000..da962cd1c95b
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2017-03-15 00:31:04.000000000 +0100
++++ b/CMakeLists.txt 2019-07-21 16:39:14.365729343 +0200
+@@ -14,6 +14,8 @@
+ set(CMAKE_AUTOMOC ON)
+ find_package(Qt5Core REQUIRED)
+ find_package(Qt5Gui REQUIRED)
++ set (CMAKE_CXX_STANDARD 11)
++ set (CMAKE_CXX_EXTENSIONS OFF)
+ else()
+ find_package(Qt4 REQUIRED)
+ # properly set up compile flags (QT_DEBUG/QT_NO_DEBUG, ...)