summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/stk/stk-4.6.2.ebuild')
-rw-r--r--media-libs/stk/stk-4.6.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/media-libs/stk/stk-4.6.2.ebuild b/media-libs/stk/stk-4.6.2.ebuild
index 725704b60639..1a28ba8457df 100644
--- a/media-libs/stk/stk-4.6.2.ebuild
+++ b/media-libs/stk/stk-4.6.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Synthesis ToolKit in C++"
HOMEPAGE="https://ccrma.stanford.edu/software/stk/"
@@ -11,8 +11,9 @@ SRC_URI="https://ccrma.stanford.edu/software/stk/release/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="alsa debug doc jack oss static-libs"
+REQUIRED_USE="|| ( alsa jack oss )"
BDEPEND="
virtual/pkgconfig
@@ -36,6 +37,8 @@ src_prepare() {
}
src_configure() {
+ use kernel_linux && append-flags -D__OS_LINUX__
+
#breaks with --disable-foo...uses as --enable-foo
local myconf
if use debug; then