summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/svt-av1/svt-av1-9999.ebuild')
-rw-r--r--media-libs/svt-av1/svt-av1-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/media-libs/svt-av1/svt-av1-9999.ebuild b/media-libs/svt-av1/svt-av1-9999.ebuild
index 5f5a2bb626bd..49270aedb7db 100644
--- a/media-libs/svt-av1/svt-av1-9999.ebuild
+++ b/media-libs/svt-av1/svt-av1-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,17 +12,21 @@ if [[ ${PV} = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/AOMediaCodec/SVT-AV1.git"
else
- SRC_URI="https://gitlab.com/AOMediaCodec/SVT-AV1/-/archive/v${PV}/SVT-AV1-v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc"
+ SRC_URI="https://gitlab.com/AOMediaCodec/SVT-AV1/-/archive/v${PV}/SVT-AV1-v${PV}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
S="${WORKDIR}/SVT-AV1-v${PV}"
fi
# Also see "Alliance for Open Media Patent License 1.0"
LICENSE="BSD-2 Apache-2.0 BSD ISC LGPL-2.1+ MIT"
-SLOT="0"
+SLOT="0/$(ver_cut 1)"
BDEPEND="amd64? ( dev-lang/yasm )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-fortify-no-override.patch
+)
+
multilib_src_configure() {
append-ldflags -Wl,-z,noexecstack
@@ -30,8 +34,10 @@ multilib_src_configure() {
# Tests require linking against https://github.com/Cidana-Developers/aom/tree/av1-normative ?
# undefined reference to `ifd_inspect'
# https://github.com/Cidana-Developers/aom/commit/cfc5c9e95bcb48a5a41ca7908b44df34ea1313c0
+ # .. and https://gitlab.com/AOMediaCodec/SVT-AV1/-/blob/master/.gitlab/workflows/linux/.gitlab-ci.yml implies it's all quite manual?
-DBUILD_TESTING=OFF
-DCMAKE_OUTPUT_DIRECTORY="${BUILD_DIR}"
+ -DENABLE_AVX512=ON
)
[[ ${ABI} != amd64 ]] && mycmakeargs+=( -DCOMPILE_C_ONLY=ON )