summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/waffle')
-rw-r--r--media-libs/waffle/Manifest1
-rw-r--r--media-libs/waffle/waffle-1.8.0.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/waffle/Manifest b/media-libs/waffle/Manifest
index aab8096d3677..2e01a0982270 100644
--- a/media-libs/waffle/Manifest
+++ b/media-libs/waffle/Manifest
@@ -1,2 +1,3 @@
DIST waffle-v1.7.2.tar.bz2 305728 BLAKE2B d78e54857d5fd4a20526d23a9a2edc5abacceaf4a2a6fd21b3432e4b68ef8084c93748592232b7698bd0587db83a5396cf92258f8cbfec2dbc1f6335d89e5bf6 SHA512 015bd82ae592d639403136e91681912827ad81b42400b7dd5353076d6af53ceec8d3cba7e9b076e99676c37a75a9e5f6440c22e14d89c978901b1e3f3d95052f
DIST waffle-v1.7.3.tar.bz2 305863 BLAKE2B efbffd252d085140f587a02e626a3eda75fd5ba3f445a03b6ae03bd74667c797f4590e63330f303dc45394353d57c9ada7973a1552ec68f0de83352719f7975e SHA512 922507b9f7b8996de0d705f0b705feeb567101d5826a0971f9267b9d58c595b2541d85c0810e43ccdaacbf4ccae0686274ce411d837e7179892ef5ab5d705b0f
+DIST waffle-v1.8.0.tar.bz2 310657 BLAKE2B cfc5f6fb32ae379457d9e1a9806504f8e2d22a2e320afab81db04a8e459cc2e127ea546e27a01a36cbb76a3095ca1d87bf96d40286f78f8ef7e1c270a6170521 SHA512 432786f1e255638a866af5c95d4ec0421ce9ffa661696482f9b40f9dbad9198f93caca484a0739a34d37d7a7070efb007771fcc6ea7acb70152c34892466e1e4
diff --git a/media-libs/waffle/waffle-1.8.0.ebuild b/media-libs/waffle/waffle-1.8.0.ebuild
new file mode 100644
index 000000000000..23baef47c53e
--- /dev/null
+++ b/media-libs/waffle/waffle-1.8.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
+ GIT_ECLASS="git-r3"
+else
+ SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}"/${PN}-v${PV}
+fi
+inherit meson-multilib multilib virtualx ${GIT_ECLASS}
+
+DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
+HOMEPAGE="https://gitlab.freedesktop.org/mesa/waffle"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc test wayland X"
+RESTRICT="!test? ( test ) test" # gl_basic tests don't work when run under sandbox
+
+RDEPEND="
+ >=media-libs/mesa-23[${MULTILIB_USEDEP}]
+ >=virtual/libudev-208:=[${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ )
+ wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ X? ( >=x11-base/xcb-proto-1.8-r3 )
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ dev-util/wayland-scanner
+"
+# test? (
+# wayland? ( dev-libs/weston[headless] )
+# )
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/wflinfo$(get_exeext)
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature X glx)
+ $(meson_feature wayland)
+ $(meson_feature X x11_egl)
+ -Dgbm=enabled
+ -Dsurfaceless_egl=enabled
+
+ $(meson_use test build-tests)
+ $(meson_native_true build-manpages)
+ -Dbuild-htmldocs=false
+ -Dbuild-examples=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ if use wayland; then
+ export XDG_RUNTIME_DIR="$(mktemp -p $(pwd) -d xdg-runtime-XXXXXX)"
+
+ weston --backend=headless-backend.so --socket=wayland-6 --idle-time=0 &
+ compositor=$!
+ export WAYLAND_DISPLAY=wayland-6
+ fi
+
+ export MESA_SHADER_CACHE_DISABLE=true
+ virtx meson_src_test
+
+ if use wayland; then
+ kill ${compositor}
+ fi
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ rm -r \
+ "${ED}"/usr/share/doc/${P} \
+ "${ED}"/usr/share/doc/waffle1/release-notes || die
+ mv "${ED}"/usr/share/doc/{waffle1,${P}} || die
+ if ! use doc; then
+ rm -rf \
+ "${ED}"/usr/share/man/man{3,7} || die
+ fi
+}