summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/xine-lib')
-rw-r--r--media-libs/xine-lib/Manifest3
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.12-dav1d-1.0.0.patch22
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.12-fix-mmap-crash.patch15
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.13-configure-clang16.patch115
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.11-r2.ebuild227
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.13-r2.ebuild (renamed from media-libs/xine-lib/xine-lib-1.2.12-r4.ebuild)49
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.9999.ebuild44
7 files changed, 166 insertions, 309 deletions
diff --git a/media-libs/xine-lib/Manifest b/media-libs/xine-lib/Manifest
index 75064b0d3a47..9cdc369cb760 100644
--- a/media-libs/xine-lib/Manifest
+++ b/media-libs/xine-lib/Manifest
@@ -1,2 +1 @@
-DIST xine-lib-1.2.11.tar.xz 5282204 BLAKE2B c61bec690f662e01372b1c068b0681ac4435925ca90a767c590d5d3b968163280c11210dc9e3aeb4cc6bb6b3520349ba22e18b17f34bd9139af02280d3a37ee3 SHA512 8208e4699819465ec9e820530f27b6129ee954ea17ab474eb9eda12137af1417ed5260830c1006ce32266a3913d22ba9957689bb5552464908038a1b8a8efbcf
-DIST xine-lib-1.2.12.tar.xz 5341212 BLAKE2B e975be2e7cf013e218001631c6b27a0d5e291605cb236c075e4b7463b30d23f3ee14aa7e18473d52efaf124f6ab0346b93591b613c6d9339f8f28e6a719b1ef8 SHA512 cdc913d0c78a3a34bd6e4060040fd844f22dbc673330e30769c83e9682a46f3369af8f59bd0c759ddc601de979b13d53e7ed10c54f3b78bdc63afceb484826be
+DIST xine-lib-1.2.13.tar.xz 5007364 BLAKE2B 8c39328b4135035e7b4070c670591e61a92443bb389af3b7da053fd68101fcb2f18cd258840e96a5f3e02d4cf979b028947a10fddd1bfc3b92ed7f18d3f58942 SHA512 269275f0e324acc559695d268fb93e0e0ca4b17d22c4a57d482365ac058ae2aed125b9e1b522c1fc501cf4b2c186ac05d921d7c82a98e094cb0c70489e61c924
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.12-dav1d-1.0.0.patch b/media-libs/xine-lib/files/xine-lib-1.2.12-dav1d-1.0.0.patch
deleted file mode 100644
index cb3253cf99a5..000000000000
--- a/media-libs/xine-lib/files/xine-lib-1.2.12-dav1d-1.0.0.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://bugs.gentoo.org/835791
-https://sourceforge.net/p/xine/tickets/11/
---- a/src/video_dec/dav1d.c
-+++ b/src/video_dec/dav1d.c
-@@ -544,11 +544,17 @@
-
- /* multithreading */
- ncpu = xine_cpu_count();
-+#if DAV1D_API_VERSION_MAJOR > 5
-+ settings.n_threads = ncpu + 1;
-+ xprintf(stream->xine, XINE_VERBOSITY_DEBUG, LOG_MODULE ": "
-+ "Using %d threads\n", settings.n_threads);
-+#else
- settings.n_frame_threads = (ncpu > 8) ? 4 : (ncpu < 2) ? 1 : ncpu/2;
- settings.n_tile_threads = MAX(1, ncpu - settings.n_frame_threads + 1);
- xprintf(stream->xine, XINE_VERBOSITY_DEBUG, LOG_MODULE ": "
- "Using %d frame threads, %d tile threads\n",
- settings.n_frame_threads, settings.n_tile_threads);
-+#endif
-
- /* dri frame allocator */
- settings.allocator.cookie = this;
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.12-fix-mmap-crash.patch b/media-libs/xine-lib/files/xine-lib-1.2.12-fix-mmap-crash.patch
deleted file mode 100644
index df5515f0495c..000000000000
--- a/media-libs/xine-lib/files/xine-lib-1.2.12-fix-mmap-crash.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://sourceforge.net/p/xine/tickets/12/
-https://sourceforge.net/p/xine/xine-lib-1.2/ci/f56d70b45346ca9363a720724b0c2d00fc798988/tree/src/input/input_file.c?diff=d6e5d46a943257f0be171fb8ab16050810a21581
-https://bugs.gentoo.org/846398
-
---- a/src/input/input_file.c
-+++ b/src/input/input_file.c
-@@ -449,7 +449,7 @@
- #ifdef HAVE_MMAP
- this->mmap_base = NULL;
- do {
-- uint8_t mmap_base;
-+ uint8_t *mmap_base;
- size_t tmp_size;
- /* may cause truncation - if it does, DON'T mmap! */
- tmp_size = (size_t)sbuf.st_size;
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.13-configure-clang16.patch b/media-libs/xine-lib/files/xine-lib-1.2.13-configure-clang16.patch
new file mode 100644
index 000000000000..387539c19344
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.2.13-configure-clang16.patch
@@ -0,0 +1,115 @@
+https://src.fedoraproject.org/rpms/xine-lib/blob/778d0883383a1e8ee4060b1d8583296812e077d4/f/xine-lib-configure-c99.patch
+
+configure: Add fake prototypes for C99 compatibility
+
+The xxmc-related configure probes assume that the compiler
+supports implicit function declarations because it tries to
+call the functions without including the appropriate headers,
+for link testing.
+
+As the headers are not determined yet at this point, use
+a fake prototype (the same that autoconf uses) to avoid
+the implicit function declarations.
+
+This avoids altering the outcome of these checks with future
+compilers which do not support implicit function declarations.
+
+Submitted upstream:
+
+ <https://sourceforge.net/p/xine/xine-lib-1.2/merge-requests/2/>
+
+--- a/configure
++++ b/configure
+@@ -28563,7 +28563,7 @@ $as_echo "" >&6; }
+ LIBS="$XXMC_LIBS $X_LIBS $XV_LIBS $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-
++char XvMCPutSlice(void);
+ int
+ main ()
+ {
+@@ -28578,7 +28578,7 @@ else
+ LIBS="$XXMC_LIBS -lXvMC $X_LIBS $XV_LIBS $LIBS $DYNAMIC_LD_LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-
++char XvMCPutSlice(void);
+ int
+ main ()
+ {
+@@ -28616,7 +28616,7 @@ done
+ else
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-
++char XvMCCreateContext(void);
+ int
+ main ()
+ {
+@@ -28631,7 +28631,7 @@ else
+ LIBS="$XXMC_LIBS -lXvMC $X_LIBS $XV_LIBS $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-
++char XvMCCreateContext(void);
+ int
+ main ()
+ {
+@@ -28675,7 +28675,7 @@ $as_echo "" >&6; }
+ LIBS="$XVMC_LIBS $X_LIBS $XV_LIBS $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-
++char XvMCCreateContext(void);
+ int
+ main ()
+ {
+@@ -28690,7 +28690,7 @@ else
+ LIBS="$XVMC_LIBS -lXvMC $X_LIBS $XV_LIBS $LIBS $DYNAMIC_LD_LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-
++char XvMCCreateContext(void);
+ int
+ main ()
+ {
+--- a/m4/video_out.m4
++++ b/m4/video_out.m4
+@@ -496,9 +496,9 @@ AC_DEFUN([XINE_VIDEO_OUT_PLUGINS], [
+ AC_MSG_CHECKING([whether to enable the xxmc plugin with VLD extensions])
+ AC_MSG_RESULT([])
+ LIBS="$XXMC_LIBS $X_LIBS $XV_LIBS $LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[XvMCPutSlice()]])], [have_xxmc=yes],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[char XvMCPutSlice(void);]], [[XvMCPutSlice()]])], [have_xxmc=yes],
+ [LIBS="$XXMC_LIBS -lXvMC $X_LIBS $XV_LIBS $LIBS $DYNAMIC_LD_LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[XvMCPutSlice()]])],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[char XvMCPutSlice(void);]], [[XvMCPutSlice()]])],
+ [have_xxmc=yes XXMC_LIBS="$XXMC_LIBS -lXvMC"])])
+ if test x"$have_xxmc" = x"yes"; then
+ AC_CHECK_HEADERS([X11/extensions/vldXvMC.h],
+@@ -506,9 +506,9 @@ AC_DEFUN([XINE_VIDEO_OUT_PLUGINS], [
+ AC_DEFINE([HAVE_VLDXVMC], 1, [Define if you have vldXvMC.h])],
+ [have_vldexts=no])
+ else
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[XvMCCreateContext()]])], [have_xxmc=yes],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[char XvMCCreateContext(void);]], [[XvMCCreateContext()]])], [have_xxmc=yes],
+ [LIBS="$XXMC_LIBS -lXvMC $X_LIBS $XV_LIBS $LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[XvMCCreateContext()]])],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[char XvMCCreateContext(void);]], [[XvMCCreateContext()]])],
+ [have_xxmc=yes XXMC_LIBS="$XXMC_LIBS -lXvMC"])])
+ fi
+ if test x"$have_xxmc" = x"yes"; then
+@@ -521,9 +521,9 @@ AC_DEFUN([XINE_VIDEO_OUT_PLUGINS], [
+ AC_MSG_CHECKING([whether to enable the xvmc plugin])
+ AC_MSG_RESULT([])
+ LIBS="$XVMC_LIBS $X_LIBS $XV_LIBS $LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[XvMCCreateContext()]])], [have_xvmc=yes],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[char XvMCCreateContext(void);]], [[XvMCCreateContext()]])], [have_xvmc=yes],
+ [LIBS="$XVMC_LIBS -lXvMC $X_LIBS $XV_LIBS $LIBS $DYNAMIC_LD_LIBS"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[XvMCCreateContext()]])],
++ AC_LINK_IFELSE([AC_LANG_PROGRAM([[char XvMCCreateContext(void);]], [[XvMCCreateContext()]])],
+ [have_xvmc=yes XVMC_LIBS="$XVMC_LIBS -lXvMC"])])
+ if test x"$have_xvmc" = x"yes"; then
+ AC_CHECK_HEADERS([X11/extensions/XvMC.h], [], [have_xvmc=no])
+
diff --git a/media-libs/xine-lib/xine-lib-1.2.11-r2.ebuild b/media-libs/xine-lib/xine-lib-1.2.11-r2.ebuild
deleted file mode 100644
index 658a811779ee..000000000000
--- a/media-libs/xine-lib/xine-lib-1.2.11-r2.ebuild
+++ /dev/null
@@ -1,227 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic libtool
-
-if [[ ${PV} == *9999* ]]; then
- EHG_REPO_URI="http://hg.code.sf.net/p/xine/xine-lib-1.2"
- inherit autotools mercurial
- unset NLS_IUSE
- NLS_DEPEND="sys-devel/gettext"
- NLS_RDEPEND="virtual/libintl"
-else
- KEYWORDS="amd64 arm64 ~hppa ppc ppc64 ~riscv x86"
- SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
- NLS_IUSE="nls"
- NLS_DEPEND="nls? ( sys-devel/gettext )"
- NLS_RDEPEND="nls? ( virtual/libintl )"
-fi
-
-DESCRIPTION="Core libraries for Xine movie player"
-HOMEPAGE="http://xine.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="1"
-IUSE="a52 aac aalib +alsa bluray cpu_flags_ppc_altivec +css dts dvb dxr3 fbcon flac gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack nfs opengl oss pulseaudio samba sftp sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack wayland +X xinerama +xv xvmc ${NLS_IUSE}"
-
-BDEPEND="
- app-arch/xz-utils
- >=sys-devel/libtool-2.2.6b
- virtual/pkgconfig
-"
-RDEPEND="${NLS_RDEPEND}
- dev-libs/libxdg-basedir
- media-libs/libdvdnav
- media-video/ffmpeg:=
- sys-libs/zlib:=
- virtual/libiconv
- a52? ( media-libs/a52dec )
- aac? ( media-libs/faad2 )
- aalib? ( media-libs/aalib )
- alsa? ( media-libs/alsa-lib )
- bluray? ( >=media-libs/libbluray-0.2.1:= )
- css? ( >=media-libs/libdvdcss-1.2.10 )
- dts? ( media-libs/libdca )
- dxr3? ( media-libs/libfame )
- flac? ( media-libs/flac:= )
- gtk? ( x11-libs/gdk-pixbuf:2 )
- imagemagick? ( virtual/imagemagick-tools )
- jack? ( virtual/jack )
- jpeg? ( media-libs/libjpeg-turbo:= )
- libcaca? ( media-libs/libcaca )
- mad? ( media-libs/libmad )
- mng? ( media-libs/libmng:= )
- modplug? ( >=media-libs/libmodplug-0.8.8.1 )
- musepack? ( >=media-sound/musepack-tools-444 )
- nfs? ( net-fs/libnfs:= )
- opengl? (
- virtual/glu
- virtual/opengl
- )
- pulseaudio? ( media-sound/pulseaudio )
- samba? ( net-fs/samba )
- sftp? ( net-libs/libssh2 )
- sdl? ( media-libs/libsdl )
- speex? (
- media-libs/libogg
- media-libs/speex
- )
- theora? (
- media-libs/libogg
- media-libs/libtheora
- )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype:2
- )
- v4l? ( media-libs/libv4l )
- vaapi? ( x11-libs/libva:=[X,opengl] )
- vcd? (
- >=media-video/vcdimager-0.7.23
- dev-libs/libcdio:=[-minimal]
- )
- vdpau? ( x11-libs/libvdpau )
- vorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
- vpx? ( media-libs/libvpx:= )
- wavpack? ( media-sound/wavpack )
- wayland? ( dev-libs/wayland )
- X? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libxcb:=
- )
- xinerama? ( x11-libs/libXinerama )
- xv? ( x11-libs/libXv )
- xvmc? ( x11-libs/libXvMC )
-"
-DEPEND="${RDEPEND}
- ${NLS_DEPEND}
- oss? ( virtual/os-headers )
- v4l? ( virtual/os-headers )
- X? (
- x11-base/xorg-proto
- x11-libs/libXt
- )
- xv? ( x11-base/xorg-proto )
- xvmc? ( x11-base/xorg-proto )
- xinerama? ( x11-base/xorg-proto )
-"
-REQUIRED_USE="
- vidix? ( || ( X fbcon ) )
- xv? ( X )
- xinerama? ( X )
-"
-
-src_prepare() {
- default
-
- sed -i -e '/define VDR_ABS_FIFO_DIR/s|".*"|"/var/vdr/xine"|' src/vdr/input_vdr.c || die
-
- if [[ "${PV}" = *9999* ]] ; then
- eautoreconf
- else
- elibtoolize
- fi
-
- local x
- for x in 0 1 2 3; do
- sed -i -e "/^O${x}_CFLAGS=\"-O${x}\"/d" configure || die
- done
-}
-
-src_configure() {
- [[ ${CHOST} == i?86-* ]] && append-flags -fomit-frame-pointer #422519
-
- local win32dir #197236
- if has_multilib_profile; then
- win32dir=/usr/$(ABI="x86" get_libdir)/win32
- else
- win32dir=/usr/$(get_libdir)/win32
- fi
-
- local myconf=(
- --disable-directfb
- --disable-gnomevfs
- --disable-optimizations
- --disable-real-codecs
- --disable-v4l
- --disable-w32dll
- --enable-avformat
- --with-external-dvdnav
- --with-real-codecs-path=/usr/$(get_libdir)/codecs
- --with-w32-path=${win32dir}
- --with-xv-path=/usr/$(get_libdir)
- --without-dav1d
- --without-esound
- --without-fusionsound
- $(use_enable a52 a52dec)
- $(use_enable aac faad)
- $(use_enable aalib)
- $(use_enable cpu_flags_ppc_altivec altivec)
- $(use_enable bluray)
- $(use_enable dts)
- $(use_enable dvb)
- $(use_enable dxr3)
- $(use_enable fbcon fb)
- $(use_enable gtk gdkpixbuf)
- $(use_enable ipv6)
- $(use_enable jpeg libjpeg)
- $(use_enable mad)
- $(use_enable mmap)
- $(use_enable mng)
- $(use_enable modplug)
- $(use_enable musepack)
- $(use_enable nfs)
- $(use_enable opengl)
- $(use_enable opengl glu)
- $(use_enable oss)
- $(use_enable samba)
- $(use_enable sftp)
- $(use_enable v4l libv4l)
- $(use_enable v4l v4l2)
- $(use_enable vaapi)
- $(use_enable vdpau)
- $(use_enable vis)
- $(use_enable vidix)
- $(use_enable xinerama)
- $(use_enable xvmc)
- $(use_enable vcd)
- $(use_enable vdr)
- $(use_enable vpx)
- $(use_enable wayland)
- $(use_with alsa)
- $(use_with flac libflac)
- $(use_with imagemagick)
- $(use_with jack)
- $(use_with libcaca caca)
- $(use_with pulseaudio)
- $(use_with sdl)
- $(use_with speex)
- $(use_with theora)
- $(use_with truetype fontconfig)
- $(use_with truetype freetype)
- $(use_with vorbis)
- $(use_with wavpack)
- $(use_with X x)
- $(use_with X xcb)
- )
- [[ ${PV} == *9999* ]] || myconf+=( $(use_enable nls) )
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- # enable verbose building, bug #448140
- emake V=1
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
- rm "${ED}"/usr/share/doc/${PF}/COPYING || die
-}
diff --git a/media-libs/xine-lib/xine-lib-1.2.12-r4.ebuild b/media-libs/xine-lib/xine-lib-1.2.13-r2.ebuild
index 2d39b5534149..e7612a609de7 100644
--- a/media-libs/xine-lib/xine-lib-1.2.12-r4.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.2.13-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit flag-o-matic libtool
+inherit flag-o-matic libtool multilib
if [[ ${PV} == *9999* ]]; then
EHG_REPO_URI="http://hg.code.sf.net/p/xine/xine-lib-1.2"
@@ -12,25 +12,28 @@ if [[ ${PV} == *9999* ]]; then
NLS_DEPEND="sys-devel/gettext"
NLS_RDEPEND="virtual/libintl"
else
- KEYWORDS="amd64 arm64 ~hppa ~ppc ~ppc64 ~riscv x86"
- SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+ SRC_URI="https://downloads.sourceforge.net/xine/${P}.tar.xz"
+ KEYWORDS="amd64 arm64 ~hppa ppc ppc64 ~riscv x86"
+ S="${WORKDIR}"/${PN}-$(ver_cut 1-2)
+
NLS_IUSE="nls"
NLS_DEPEND="nls? ( sys-devel/gettext )"
NLS_RDEPEND="nls? ( virtual/libintl )"
fi
DESCRIPTION="Core libraries for Xine movie player"
-HOMEPAGE="http://xine.sourceforge.net/"
+HOMEPAGE="https://xine.sourceforge.net/"
LICENSE="GPL-2"
SLOT="1"
-IUSE="a52 aac aalib +alsa bluray cpu_flags_ppc_altivec +css dav1d dts dvb dxr3 fbcon flac gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack nfs opengl oss pulseaudio samba sftp sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack wayland +X xinerama +xv xvmc ${NLS_IUSE}"
-
-BDEPEND="
- app-arch/xz-utils
- >=sys-devel/libtool-2.2.6b
- virtual/pkgconfig
+IUSE="a52 aac aalib +alsa bluray cpu_flags_ppc_altivec +css dav1d dts dvb dxr3 fbcon flac gtk imagemagick jack jpeg libcaca mad +mmap mng modplug musepack nfs opengl oss pulseaudio samba sftp sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack wayland +X xinerama +xv xvmc ${NLS_IUSE}"
+REQUIRED_USE="
+ vidix? ( || ( X fbcon ) )
+ wayland? ( opengl )
+ xv? ( X )
+ xinerama? ( X )
"
+
RDEPEND="
dev-libs/libxdg-basedir
media-libs/libdvdnav
@@ -61,7 +64,7 @@ RDEPEND="
virtual/glu
virtual/opengl
)
- pulseaudio? ( media-sound/pulseaudio )
+ pulseaudio? ( media-libs/libpulse )
samba? ( net-fs/samba )
sftp? ( net-libs/libssh2 )
sdl? ( media-libs/libsdl )
@@ -78,7 +81,7 @@ RDEPEND="
media-libs/freetype:2
)
v4l? ( media-libs/libv4l )
- vaapi? ( x11-libs/libva:=[X] )
+ vaapi? ( media-libs/libva:=[X] )
vcd? (
>=media-video/vcdimager-0.7.23
dev-libs/libcdio:=[-minimal]
@@ -94,13 +97,14 @@ RDEPEND="
X? (
x11-libs/libX11
x11-libs/libXext
- x11-libs/libxcb
+ x11-libs/libxcb:=
)
xinerama? ( x11-libs/libXinerama )
xv? ( x11-libs/libXv )
xvmc? ( x11-libs/libXvMC )
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
oss? ( virtual/os-headers )
v4l? ( virtual/os-headers )
X? (
@@ -111,15 +115,14 @@ DEPEND="${RDEPEND}
xvmc? ( x11-base/xorg-proto )
xinerama? ( x11-base/xorg-proto )
"
-REQUIRED_USE="
- vidix? ( || ( X fbcon ) )
- xv? ( X )
- xinerama? ( X )
+BDEPEND="
+ app-arch/xz-utils
+ >=dev-build/libtool-2.2.6b
+ virtual/pkgconfig
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.2.12-dav1d-1.0.0.patch
- "${FILESDIR}"/${PN}-1.2.12-fix-mmap-crash.patch
+ "${FILESDIR}"/${PN}-1.2.13-configure-clang16.patch
)
src_prepare() {
@@ -157,6 +160,7 @@ src_configure() {
--disable-v4l
--disable-w32dll
--enable-avformat
+ --enable-ipv6
--with-external-dvdnav
--with-real-codecs-path=/usr/$(get_libdir)/codecs
--with-w32-path=${win32dir}
@@ -175,7 +179,6 @@ src_configure() {
$(use_enable dxr3)
$(use_enable fbcon fb)
$(use_enable gtk gdkpixbuf)
- $(use_enable ipv6)
$(use_enable jpeg libjpeg)
$(use_enable mad)
$(use_enable mmap)
@@ -219,7 +222,7 @@ src_configure() {
)
[[ ${PV} == *9999* ]] || myconf+=( $(use_enable nls) )
- econf "${myconf[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myconf[@]}"
}
src_compile() {
diff --git a/media-libs/xine-lib/xine-lib-1.2.9999.ebuild b/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
index 645dce42fdb3..4215104fe58c 100644
--- a/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.2.9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit flag-o-matic libtool
+inherit flag-o-matic libtool multilib
if [[ ${PV} == *9999* ]]; then
EHG_REPO_URI="http://hg.code.sf.net/p/xine/xine-lib-1.2"
@@ -12,25 +12,28 @@ if [[ ${PV} == *9999* ]]; then
NLS_DEPEND="sys-devel/gettext"
NLS_RDEPEND="virtual/libintl"
else
+ SRC_URI="https://downloads.sourceforge.net/xine/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
- SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
+ S="${WORKDIR}"/${PN}-$(ver_cut 1-2)
+
NLS_IUSE="nls"
NLS_DEPEND="nls? ( sys-devel/gettext )"
NLS_RDEPEND="nls? ( virtual/libintl )"
fi
DESCRIPTION="Core libraries for Xine movie player"
-HOMEPAGE="http://xine.sourceforge.net/"
+HOMEPAGE="https://xine.sourceforge.net/"
LICENSE="GPL-2"
SLOT="1"
-IUSE="a52 aac aalib +alsa bluray cpu_flags_ppc_altivec +css dav1d dts dvb dxr3 fbcon flac gtk imagemagick ipv6 jack jpeg libcaca mad +mmap mng modplug musepack nfs opengl oss pulseaudio samba sftp sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack wayland +X xinerama +xv xvmc ${NLS_IUSE}"
-
-BDEPEND="
- app-arch/xz-utils
- >=sys-devel/libtool-2.2.6b
- virtual/pkgconfig
+IUSE="a52 aac aalib +alsa bluray cpu_flags_ppc_altivec +css dav1d dts dvb dxr3 fbcon flac gtk imagemagick jack jpeg libcaca mad +mmap mng modplug musepack nfs opengl oss pulseaudio samba sftp sdl speex theora truetype v4l vaapi vcd vdpau vdr vidix +vis vorbis vpx wavpack wayland +X xinerama +xv xvmc ${NLS_IUSE}"
+REQUIRED_USE="
+ vidix? ( || ( X fbcon ) )
+ wayland? ( opengl )
+ xv? ( X )
+ xinerama? ( X )
"
+
RDEPEND="
dev-libs/libxdg-basedir
media-libs/libdvdnav
@@ -61,7 +64,7 @@ RDEPEND="
virtual/glu
virtual/opengl
)
- pulseaudio? ( media-sound/pulseaudio )
+ pulseaudio? ( media-libs/libpulse )
samba? ( net-fs/samba )
sftp? ( net-libs/libssh2 )
sdl? ( media-libs/libsdl )
@@ -78,7 +81,7 @@ RDEPEND="
media-libs/freetype:2
)
v4l? ( media-libs/libv4l )
- vaapi? ( x11-libs/libva:=[X] )
+ vaapi? ( media-libs/libva:=[X] )
vcd? (
>=media-video/vcdimager-0.7.23
dev-libs/libcdio:=[-minimal]
@@ -100,7 +103,8 @@ RDEPEND="
xv? ( x11-libs/libXv )
xvmc? ( x11-libs/libXvMC )
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
oss? ( virtual/os-headers )
v4l? ( virtual/os-headers )
X? (
@@ -111,10 +115,10 @@ DEPEND="${RDEPEND}
xvmc? ( x11-base/xorg-proto )
xinerama? ( x11-base/xorg-proto )
"
-REQUIRED_USE="
- vidix? ( || ( X fbcon ) )
- xv? ( X )
- xinerama? ( X )
+BDEPEND="
+ app-arch/xz-utils
+ >=dev-build/libtool-2.2.6b
+ virtual/pkgconfig
"
src_prepare() {
@@ -152,6 +156,7 @@ src_configure() {
--disable-v4l
--disable-w32dll
--enable-avformat
+ --enable-ipv6
--with-external-dvdnav
--with-real-codecs-path=/usr/$(get_libdir)/codecs
--with-w32-path=${win32dir}
@@ -170,7 +175,6 @@ src_configure() {
$(use_enable dxr3)
$(use_enable fbcon fb)
$(use_enable gtk gdkpixbuf)
- $(use_enable ipv6)
$(use_enable jpeg libjpeg)
$(use_enable mad)
$(use_enable mmap)
@@ -214,7 +218,7 @@ src_configure() {
)
[[ ${PV} == *9999* ]] || myconf+=( $(use_enable nls) )
- econf "${myconf[@]}"
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myconf[@]}"
}
src_compile() {